Project

General

Profile

Emulator Issues #11845

[macOS] Freeze on changing any configuration setting

Added by elmeyer 6 months ago. Updated 2 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
OS X
Issue type:
Bug
Milestone:
Current
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem? Describe what went wrong.

Upon changing any setting in the settings UI, Dolphin freezes and needs to be force quit.

What steps will reproduce the problem?

  1. Open Dolphin.
  2. Open the Settings window.
  3. Change any setting.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes. Latest development version at the time of writing is 5.0-10906.

Is the issue present in the latest stable version?

No.

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

5.0-10855 (Threading fixes for config layers (PR #8273 by CookiePLMonster))

What are your PC specifications? (CPU, GPU, Operating System, more)

MacBook Pro 15", Mid 2014, Intel Core i7-4770HQ, Intel Iris Pro Graphics 5200, macOS Mojave 10.14.6 (18G87).


Related issues

Is duplicate of Emulator - Emulator Issues #11919: Dolphin hangs with a clean configuration on macOS 10.14.6 when attempting to close Dolphin or open the 'Controllers' config UIFixed

History

#1 Updated by elmeyer 6 months ago

I believe #11842 refers to the same issue.

#2 Updated by Pizuz 6 months ago

I can reproduce this.

#3 Updated by gilcel 5 months ago

Hmm, didn't have any freezes when changing Settings on macMini 2010, macMini 2012 (macOS 10.4.6) or macMini 2018 (macOS 10.4.6)...

#4 Updated by Pizuz 5 months ago

Strange, even on the most recent version (5.0-10912) I still get freezes as soon as I click on the Dual-Core checkbox, for instance.

iMac Late 2012 with macOS 10.14.6 here.

#5 Updated by Pizuz 4 months ago

Still freezing. Upgrading to Catalina and updating Dolphin to 5.0-10965 still freezes on clicking any checkbox in the general configuration window.

#6 Updated by drylemon 4 months ago

Simply clicking on the "Controllers" icon is enough to freeze the UI indefinitely for me. Dolphin version 5.0-10979.

MacBook Air (Retina, 13-inch, 2018) running Mojave 10.14.6

#7 Updated by JosJuice 4 months ago

  • Milestone set to Current
  • Operating system OS X added
  • Operating system deleted (N/A)

#8 Updated by JosJuice 2 months ago

  • Is duplicate of Emulator Issues #11919: Dolphin hangs with a clean configuration on macOS 10.14.6 when attempting to close Dolphin or open the 'Controllers' config UI added

#9 Updated by JosJuice 2 months ago

  • Status changed from New to Duplicate

Also available in: Atom PDF