Project

General

Profile

Emulator Issues #11850

Dolphin shows up In Discord as "Dolphin by Activision"

Added by Bombastisch 4 months ago. Updated 4 months ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem? Describe what went wrong.

Discord usually shows the game one is playing next to the name. It also shows the game's publisher/studio.

Dolphin also shows up in discord, since it's integrated. but it shows the wrong publischer. Namely Activison.

Probably a fail-save? Ac(tivision) seems like it could be the first in the alphabet. You might have to get into contact with Discord again to replace it with something like "Dolphin Team".

What steps will reproduce the problem?

Enable Discord presence in Dolphin and open Discord and click on your name in the bottom left side of the screen to see the game-status.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes. 5.0-10910

Is the issue present in the latest stable version?

No, because it lacks the Discord presence

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

See screenshot

2019-09-09 (1).png (225 KB) 2019-09-09 (1).png Bombastisch, 09/08/2019 10:27 PM
7555

History

#1 Updated by JosJuice 4 months ago

  • Status changed from New to Invalid

This happens regardless of Dolphin's Discord integration as far as I can tell. (Or did you specifically test that it doesn't happen with 5.0?) The reason it's happening is because Discord has some sort of database of games, which includes an Atari 2600 game by Activision called Dolphin.

Since this is a problem on Discord's side rather than ours, I'm closing this issue. I don't think Discord are more likely to accept a report on their side from a Dolphin developer rather than from some other person who uses Dolphin.

#2 Updated by Helios 4 months ago

Users aren't supposed to know we're on Activisions payroll.

Also available in: Atom PDF