Project

General

Profile

Emulator Issues #11859

Pac-Man World 3 (PAL/EU) - Broken Elevators

Added by Mario123311 over 1 year ago. Updated over 1 year ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Pac-Man World 3 (Disc 0, Revision 0)

Game ID? (right click the game in the game list, Properties, Info tab)

GP8P69

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

2ab9caf12b9a03d8272190d03d77d122

What's the problem? Describe what went wrong.

Elevators in the first level, Bot Boneyard are broken. While the ones prior to it don't exactly break the game, The final one to exit the level does. After using the Rev-Roll plate the elevator drops down and then bounces back up, flying off to infinity.

What steps will reproduce the problem?

After using the Rev-Roll plate the elevator drops down and then bounces back up, flying off to infinity.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes 5.0-10758

Is the issue present in the latest stable version?

Unsure

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

5.0 as far as I'm aware, And it's never been fixed.

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

Windows 10 i7-65000U CPU @ 2.50 GHz 2.60 GHz
16.0 GB RAM
64 bit
AMD Radeon R5 M335

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

https://youtu.be/O6yV7uzrDG8 Recording of the glitch

History

#1 Updated by JMC4789 over 1 year ago

Can you try making a savestate prior to it falling and switching to Cached Interpreter, then loading the savestate and seeing if it still fails?

#2 Updated by Mario123311 over 1 year ago

JMC4789 wrote:

Can you try making a savestate prior to it falling and switching to Cached Interpreter, then loading the savestate and seeing if it still fails?

Here you are, Please note this is for the PAL/EU version of the game, Not the typical USA release. https://www.mediafire.com/file/qfu1pbfqyw2o4cp/mp.sav/file

#3 Updated by shellashock over 1 year ago

For the record, I just tested this elevator in Level 1 on 5.0-10928 on an NA copy of PMW3 and can't reproduce with any combination of JIT Recompiler, Cached Interpreter, HLE, or LLE Recompiler. Seems to be a PAL only issue.

OP, did you test this with HLE, LLE Recompiler or LLE Interpreter? Back in late 2012 (when new-AX-HLE was being implemented), I noticed that a specific elevator that triggered a cutscene in Level 4 of PMW3 (NA) did not work with HLE and would only work with LLE. A few years and thousands of revisions later in late 2014, I noticed that both HLE and LLE were working for this elevator and you could progress normally while testing for an unrelated graphical issue.

I don't know the specific revision that fixed that and I lost my old save file directly at that point so I can't immediately re-test; but my point is that at least one issue with PMW3's elevators was related to audio inaccuracies.

Hope this helps!

#4 Updated by JMC4789 over 1 year ago

It's possible it's a PAL only issue. I imported the PAL version of the game but I'm too lazy to find the elevators at this time. by the time I got the game, the savestates were for outdated builds.

#5 Updated by Mario123311 over 1 year ago

JMC4789 wrote:

It's possible it's a PAL only issue. I imported the PAL version of the game but I'm too lazy to find the elevators at this time. by the time I got the game, the savestates were for outdated builds.

Issue now seems to be fixed on the latest devbuild of Dolphin. I'm now able to finish level 1 properly.

#6 Updated by JMC4789 over 1 year ago

  • Status changed from New to Fixed

Interesting. I wonder what fixed it. Either way, I'll take it. MCRFS fix maybe?

Also available in: Atom PDF