Project

General

Profile

Emulator Issues #11863

Nicktoons Unite! (USA)

Added by hyperspider about 2 months ago. Updated 26 days ago.

Status:
Accepted
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Nicktoons Unite! (USA)

Game ID? (right click the game in the game list, Properties, Info tab)

GNOE78

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

232fce9fef02b7bf2df4d77f3f479521

What's the problem? Describe what went wrong.

When playing the game, there will be a rectangular blur present in the upper left part of the screen during levels (or a black box in older versions of Dolphin), and some sort of image corruption on the top and left edges of the screen.

What steps will reproduce the problem?

  1. Start the game
  2. Load a level (tested most heavily on "The Jellyfish Factory")
  3. The blur box/black box will be there in the upper left, and the image corruption will be on the top and left edges.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, 5.0-10914 (in this version, the box is a blur effect)

Is the issue present in the latest stable version?

No, 5.0

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

First broken version is 5.0-6860 (here the box is black, but in the same place as the blur)
Everything works fine in 5.0-6858

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

Attached as 3-frame-fifo-log.7z (compressed as 7z for upload limit)
Additionally included 3 screenshots:
- one working normally from 5.0-6858 (working.jpg)
- one with the initial black box appearance from 5.0-6860 (black box.jpg)
- one with the current blur box appearance from 5.0-10914 (blur.jpg) - you can see the difference between the blurred and non-blurred areas if you look at Jimmy's shoes and the large shadow on the ground next to him (Jimmy is the one with the swirly brown hair)

What are your PC specifications? (CPU, GPU, Operating System, more)

Win10 x64
GPU: Nvidia GTX 1080
CPU: Intel i7-6700K at 4.0 GHz
Computer runs at 1440p165Hz

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

I tried changing the internal resolution (lowering this just made the box bigger), disabling the widescreen hack and using the normal 4:3 aspect ratio, switching back to Synchronous mode (no Ubershaders) from Async Ubershaders, and the various backends, none of which worked.
I took a quick look at the commit for the first broken version, and it looks like this is directly related to removing projection hacks (the GNO ini file for this game is specifically modified).

black box.jpg (416 KB) black box.jpg Screenshot of the game with a black box, in 5.0-6860 where it initially broke hyperspider, 09/24/2019 03:38 AM
3-frame-fifo-log.7z (641 KB) 3-frame-fifo-log.7z The 3-frame FIFO log, as requested hyperspider, 09/24/2019 03:38 AM
blur.jpg (620 KB) blur.jpg Screenshot of the game with the blur, in 5.0-10914 how it looks now hyperspider, 09/24/2019 03:38 AM
working.jpg (700 KB) working.jpg Screenshot of the game working in 5.0-6858 hyperspider, 09/24/2019 03:38 AM
7571
7573
7574

History

#1 Updated by Billiard26 about 1 month ago

  • Status changed from New to Accepted
  • Subject changed from Nicktoons Unite! (USA) to Nicktoons Unite! (USA)

FYI. Seems to work when you disable "Defer EFB Copies to RAM".

#2 Updated by hyperspider 26 days ago

Billiard26 wrote:

FYI. Seems to work when you disable "Defer EFB Copies to RAM".

I just checked in v5.0-11050, and it has that option set to false in GNO.ini, but the issue is still occurring.

Also available in: Atom PDF