Project

General

Profile

Emulator Issues #11892

SDL2 input is NOT enabled by default on macOS on official builds

Added by underdisk 13 days ago. Updated 11 days ago.

Status:
Accepted
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
OS X
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem? Describe what went wrong.

Due to the IOKit code having some problems, the choice was made to switch the input backend to SDL2 by default on macOS (https://github.com/dolphin-emu/dolphin/pull/8406)

By building the latest source code by hand, no issues. (https://i.imgur.com/X2SzSJc.png)

But the official build from the website just does the same as before, and the SDL2 backend isn't available. (https://i.imgur.com/g0dis0I.png)

(notice the "[disconnected]")

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Problem present in the 11107 build available on the website
Problem NOT present in the 11107 build with the latest available source code

What are your PC specifications? (CPU, GPU, Operating System, more)

macOS 14.4
CMake 3.14.2

...

I got a controller sensible to the problems and a Mac. Contact me if you need to try something

History

#1 Updated by Billiard26 11 days ago

  • Status changed from New to Accepted
  • Operating system OS X added
  • Operating system deleted (N/A)

Also available in: Atom PDF