Project

General

Profile

Emulator Issues #11895

Custom Robo - CPU players unavailable in versus mode

Added by slaszt 8 months ago. Updated 8 months ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Custom Robo

Game ID? (right click the game in the game list, Properties, Info tab)

GXCE01

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

546e5108173bceb4d5c8ca27b3fcfc96

What's the problem? Describe what went wrong.

I was trying to play versus mode with 2 human players and 2 CPU players but when I go to select P1+P2 vs. CPU+CPU the CPU options are greyed out. I checked the other versus modes and the CPU option is greyed out for all of them. However, P3 and P4 are available, despite controllers 3 and 4 being set to "none."

I am using 2 Xbox One controllers connected via Bluetooth on Windows 10.

What steps will reproduce the problem?

2 controllers connected, 2 set to none. Open the game and select versus mode. Select 2v2. Once the menu to select the player configuration appears, you should see that the CPU options are unavailable.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, 5.0-11215.

Is the issue present in the latest stable version?

Yes, 5.0.

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

Not applicable, issue is present in latest stable version.

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

Not applicable, not a graphical issue.

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel i5-4460
AMD Radeon RX580 8GB
24GB DDR3 RAM
Windows 10 Pro 64-bit, version 1903

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

One thing that I found strange is that, if I go into the options menu in-game and select controller configuration, it shows that controller 3 and 4 are disconnected but still won't let me play with a CPU player.

History

#1 Updated by Techjar 8 months ago

This doesn't sound like an issue, but just the way the game is designed.

#2 Updated by slaszt 8 months ago

Techjar wrote:

This doesn't sound like an issue, but just the way the game is designed.

I grew up playing this game as a kid on an actual console, the normal behaviour is for P3+P4 to be greyed out options and the CPU options to be available. CPU battles aren't supposed to be greyed out.

There's a thread on the Dolphin subreddit that also mentions this issue but doesn't give much information and never received any responses: https://www.reddit.com/r/DolphinEmulator/comments/aaxqnu/

I'm sorry I don't have more info, but this isn't the way the game is designed.

#3 Updated by Techjar 8 months ago

That's not surprising given that subreddit is unofficial and basically nobody from the dev team browses it as far as I know.

Not sure why CPU wouldn't be selectable on Dolphin, we should be reporting controllers set to "none" as disconnected. I'll see if someone with the game can take a look.

#4 Updated by slaszt 8 months ago

Much appreciated. I don't mean to be a pain with the lack of info but it's apparently not just me and not just on PC based on that thread. If you need any specific logs or other files I'll do my best to upload them.

#5 Updated by Techjar 8 months ago

It's alright, there's not much more info we can ask for given the nature of this issue.

#6 Updated by Techjar 8 months ago

Just for the record, does the game also not let you select CPU for player 2 with that controller actually connected?

#7 Updated by slaszt 8 months ago

Yes, all CPU options are greyed out no matter which controllers are actually connected. It's quite weird. In 2v2, for example, all possibilities except for P1+P2+P3+P4 are greyed out.

#8 Updated by Techjar 8 months ago

Well it's pretty silly that the game doesn't let you select CPU for a player when the corresponding controller is plugged in.

#9 Updated by slaszt 8 months ago

I agree. I also have a mix of 3rd party and official Gamecube controllers and a Mayflash 4-controller adapter for PC, so I'm going to try those and see if the issue persists. I'll let you know what I find out.

#10 Updated by slaszt 8 months ago

slaszt wrote:

I agree. I also have a mix of 3rd party and official Gamecube controllers and a Mayflash 4-controller adapter for PC, so I'm going to try those and see if the issue persists. I'll let you know what I find out.

Tried it with both a Mayflash 4-controller adapter and a Mayflash 2-controller adapter and neither option worked correctly. I used 1 3rd party and 1 official GC controller, configuring them before booting the game with each adapter. Hope that helps in some way.

Also available in: Atom PDF