Project

General

Profile

Emulator Issues #119

Adding h4m Movie playback support

Added by Kronox.i about 12 years ago.

Status:
Fixed
Priority:
Low
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Running any game wich uses h4m for movie playback

What is the expected output? What do you see instead?

The movie should play as in the real gamecube, instead the screens just
goes black and the fps counter still runs

What version of the product are you using? On what operating system?

Rev 5-164 Running dolphin on Windows Xp 64 Professional

Please provide any additional information below.

H4M Movie Playback is not supported.
Additionally i've been looking in Gcube 0.3 source triying to find the
solution, If you aren't aware of this... Gcube can play H4M files.

Games known to have this issue
-Naruto taisen saga
-Bloody Roar saga
-Pikmin movie trailer inside luigi's mansion
-Hudson made games


Related issues

Has duplicate Emulator - Emulator Issues #1335: Pikmin Movie in Luigi's Mansion not workDuplicate

History

#1 Updated by hrydgard about 12 years ago

  • Status changed from New to Accepted

Star Soldier by Hudson shows its tiny intro movie perfectly.

I take it you are running 64-bit Dolphin?

The solution won't be found in gcube's sources. It's the PowerPC code that decodes
h4m, and if that's not working, it's either a CPU emulation bug, or the game uses the
GPU in some tricky way to display the results.

Will look into it asap, but working on lots of other things right now. with some
luck, I'll fix the cpu bug by accident :P

#2 Updated by Kronox.i about 12 years ago

Oh sorry i tried to make a good report and somehow miss that. Yeah, i'm using X64
builds, but i get the same results on x86 builds

Thanks for the answers

#3 Updated by bigjeffjohn about 12 years ago

And thank you Kronox.i, for making the report about it. I am also another user that
experiences the same problem with these .h4m movie files, which even when played with
gcube will not play them, it only crashes before starting(Bloody Roar: PF).

Thank you dolphin team for your consideration and good luck :)

#4 Updated by bigjeffjohn almost 12 years ago

Hey guys, I just wanted to know if you are still able to find the time to check out
that h4m playback bug in dolphin, please?

#5 Updated by XTra.KrazzY almost 12 years ago

Weirdly enough, I see a green screen on both JIT and interpreter in Luigi's Mansion's
Pikmin trailer... Also, I disabled optimize quantizers.

#6 Updated by bigjeffjohn almost 12 years ago

Would that mean that h4m playback is starting to work or something else?

#7 Updated by XTra.KrazzY almost 12 years ago

It doesn't work for me at all, so I don't know.

#8 Updated by XTra.KrazzY almost 12 years ago

  • Priority changed from Normal to Low
  • Operating system N/A added

HVQM4 1.3 playback

#9 Updated by omegadox almost 12 years ago

I have made a GCM from some unpacked TGC that had a .h4m file inside. I hear sound
but I only see a black screen, then the audio freezes after 3 seconds.

#10 Updated by bigjeffjohn almost 12 years ago

Indeed, the main effect of the absence of .h4m playback is the black screen that has
continuous fps but nothing is happening.

#11 Updated by XTra.KrazzY almost 12 years ago

How do I unpack a tgc file?

#12 Updated by knuckles500 almost 12 years ago

You need to convert it to a GCM, then you can open it up in your favorite tool. :)

All you need to do is drag and drop the tgc file onto this cmd program:

http://dl.getdropbox.com/u/38216/tgctogcm.exe

Have fun.

#13 Updated by bigjeffjohn over 11 years ago

Has there been any fix to the h4m support lately, because Bloody Roar primal fury
still doesn't work without renaming the movie folder in the iso. Please look in this
as soon as possible.:)

#14 Updated by omegadox over 11 years ago

I bet it works, its just that graphics part is not showing, and the sound dying
probably due to the buggy DSP.

#15 Updated by bigjeffjohn over 11 years ago

Ok, that may be true, but have you tested any games that use .h4m playback and still
works?

#16 Updated by omegadox over 11 years ago

I tested a GCM that only plays a .h4m file and the screen is black and sound works
for 3 seconds.

#17 Updated by bigjeffjohn over 11 years ago

Hmm... Ok, I will try again with Bloody Roar, but this issue needs to be resolved
once and for all.

#18 Updated by omegadox over 11 years ago

I'd say its a problem with the CPU, tho it seems like the movie plays. I think the
bug could be similar to the Zelda NES problem. Is there some mode the HW has for 2D
drawing?

#19 Updated by masterzorag over 11 years ago

Maybe issue 840 is reconducible to this?
Tatsunoko VS Capcom won't get into opening trailer

#20 Updated by omegadox over 11 years ago

Open the disk contents and see if it has a .h4m file on it.

#21 Updated by knuckles500 about 11 years ago

Just wondering, what ever happened to this? The result seems to vary depending on
what the h4m file is used for. For example, demo disks that contain TGC files (which
still need to be emulated so they open within the emulator so I dont have to convert
them to gcm in order to play them coughcough also sonic gems collection) with H4M
movies within them play sound for a split second with maybe some video and then it
completely goes blank - no sound or anything.

Wonder how come we're still having trouble with this.

#22 Updated by XTra.KrazzY about 11 years ago

I completely agree, this should be looked upon more seriously.

#23 Updated by sl1nk3.s about 11 years ago

issue 1335 has been merged into this issue.

#24 Updated by sl1nk3.s about 11 years ago

as of lately, h4m video of Pikmin in Luigi's Mansion shows the correct picture, but
it freezes after a few seconds..

#25 Updated by omegadox almost 11 years ago

Must be DSP issue then.

#26 Updated by omegadox over 10 years ago

I don't believe it is a DSP issue, but an issue with quantizers.

#27 Updated by XTra.KrazzY over 10 years ago

Luigi's is still not working yet.

#28 Updated by XTra.KrazzY over 10 years ago

issue 2025 has been merged into this issue.

#29 Updated by mbc07 about 10 years ago

Sometimes the pikmin movie trailer in Luigi's mansion play perfect using r4495 and JITiL. In newer revisions the video play for 10 seconds, after this, screen turns black but audio continue for + or - 30 seconds

#30 Updated by ryan.hoss about 10 years ago

I'd love for someone to get .h4m support working in Dolphin. You can add Batman: Dark Tomorrow to the list of games that need this.

#31 Updated by MofoMan2000 about 10 years ago

And it's still broken. I believe this is the only thing keeping 007: NightFire from getting ingame. It's funny because the video kind of plays (with no sound), and if you try to skip it by pressing start or letting the video finish, the emulator completely freezes up and uses 100% of one CPU, so I think it's getting caught in an infinite loop on the CPU thread or something. It never gives any panic alerts, so no help there.

This issue probably ought to be given higher priority at this point, it has been here a LONG time (one of the first) and is a matter of emulation accuracy that is keeping many games unplayable.

#32 Updated by MNBVCXZLKJHGFDSAPIUYTREWQ almost 10 years ago

The luigi's mansion pikmin movie works perfectly when ran with r6347 as far as I know

#33 Updated by sl1nk3.s almost 10 years ago

  • Status changed from Accepted to Fixed

Yep, it was already fixed in r6319, I really wonder what fixed it now :)
Can anyone confirm it is fixed in other games ?

MofoMan2000 > the issue in Nightfire is unrelated, it's a "FIFO crash", the game used to work at some point, also only the first level is broken.

#34 Updated by ryan.hoss almost 10 years ago

Tried Batman: Dark Tomorrow with r6356--the H4M video cutscenes still don't work for me.

#35 Updated by skidau almost 10 years ago

I've just tried Batman: Dark Tomorrow with r6360, the OGL plug-in and Real XFB enabled. The video cut-scenes are working (the video begins with "Kemco Presents").

#36 Updated by EmanModnar almost 10 years ago

The problem I first described in issue 2026, which was merged into this one, is still present; specifically, the audio for the movies in the BMX games no longer plays back at the correct rate. I can see how the issue as I wrote it back then would be merged into this one, because I made the scope too broad. So, should I create a new issue for it, or can someone un-merge 2026 from this one?

#37 Updated by skidau almost 10 years ago

We have an existing issue for slow audio in movies. I have merged issue 2025 into issue 3449.

#38 Updated by EmanModnar almost 10 years ago

Whoops. How did I get the number wrong? Thanks Skidau.

#39 Updated by kolano over 9 years ago

Just tried the Luigi's Mansion trailer.

I wasn't able to iterate through all the plug-in combos but I can confirm the following...
-The US/EU releases hang with the DX9 and HLE audio plug-ins.
-The US release plays the trailer with the DX9 and LLE audio plug-ins.
-The EU release still hangs post the first frame of the trailer regardless of the audio plug-in used.
-On both US and EU releases the OpenGL plug-in crashes post the initial menu.

#40 Updated by kolano over 9 years ago

Windows 7 x64, r6658 /w SSE 4.2 Opts

Also available in: Atom PDF