Project

General

Profile

Emulator Issues #11900

Super Paper Mario

Added by Ton1uwu 2 months ago. Updated 2 months ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Super Paper Mario

Game ID? (right click the game in the game list, Properties, Info tab)

R8PE01

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

a0d3a03aa21dee170ecd4be358a776db

What's the problem? Describe what went wrong.

When trying to start a new game the screen goes black and there is a high pitch noise, nothing happens.

What steps will reproduce the problem?

Creating New File and starting the game.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Im using Dolphin 5.0-11268

Is the issue present in the latest stable version?

Yes Dolphin 5.0

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

Core i5 8400
GTX 1080
G.Skillz 16GB 2133 Mhz
Windows 10 1903

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Anything you ask for

History

#1 Updated by JosJuice 2 months ago

  • Status changed from New to Invalid

a0d3a03aa21dee170ecd4be358a776db is not a known hash. Please redump the game (in ISO format) so that we can exclude the possibility that the copy of the game is faulty. We can reopen the issue after that.

#2 Updated by Simonx22 2 months ago

I can't reproduce this issue. My hash is 2740fc6cd66b1523cd358995f68c8840. Seems like nkit is causing this problem for some reason.

#3 Updated by Simonx22 2 months ago

Just tested this. I compressed my game with nkit and now it's crashing. But it works fine without the nkit compression.

#4 Updated by JosJuice 2 months ago

Nanook has done some testing, and it seems like the cause is files on the disc not being 32k aligned. The same problem happens on console.

So, in conclusion: Use a good dump and it'll work. (Maybe Nanook will also release an update to NKit to handle this problem, we'll see.)

#5 Updated by JosJuice 2 months ago

That turned out to not be the underlying cause. When the game reads setup/aa1_01.dat, it doesn't just read the data of the file, but also a few extra bytes beyond the file, so that the length of the disc read (or the offset of the end of the disc read?) is divisible by 0x20. If these extra bytes are 0, the game works. I'm not sure if it breaks for all non-zero values, but there are certainly some where it breaks. Cases where the bytes are not 0 and the game fails include having the files packed together too tightly (making the read of the first file include data from the beginning of the next file), and having the NKit "gap data" be present after the file.

#6 Updated by JosJuice 2 months ago

I have created a pull request that makes the Verify tab warn you if you have a disc image that's affected by this: https://github.com/dolphin-emu/dolphin/pull/8499

#7 Updated by Ton1uwu 2 months ago

Thank you guys for the fast response, Now that i know is the game format I'll just redump the game.

Also available in: Atom PDF