Project

General

Profile

Emulator Issues #11908

Save state/load state becomes super slow very early

Added by Infamousknight 4 months ago. Updated 4 months ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

[Put Game Name here]
Simpsons hit and run gamecube

Game ID? (right click the game in the game list, Properties, Info tab)

[Put Game ID here]

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

[Put MD5 Hash here]

What's the problem? Describe what went wrong.

[Description here]
While making a tas, save states become very slow about 5 minutes in.

What steps will reproduce the problem?

Start a new game, talk to marge, accept the quest, get to the market, when getting the cola, exit and start making save states and loading them when you find a new car

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

[Version number here]
50-11102-dirty

Is the issue present in the latest stable version?

[Yes/No and version number here]
No
If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

[PC specs here]
CPU:
Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP
L2 cache: 8192 KiB
Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 800
3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
Graphics:
Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
Display: x11 server: X.Org 1.20.5 driver: i915 resolution: 1366x768~60Hz
OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2)
v: 4.6 Mesa 20.0.0-devel (git-5d58fea 2019-11-26 eoan-oibaf-ppa)
Audio:
Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
Sound Server: ALSA v: k5.3.0-23-generic

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Vulkan video backend. Culeb audio backend enabled Compile before shaders enabled. Dual core speedup turned off.
[Anything else here]

History

#1 Updated by Infamousknight 4 months ago

Running Ubuntu 19.10 64 bit

#2 Updated by Infamousknight 4 months ago

Resolved: I did further testing this morning, and its a better idea to slow the game down so it can catch up easier.

Could we close this issue now?

Also available in: Atom PDF