Project

General

Profile

Emulator Issues #11926

Pokemon Colosseum/XD link to VBA-M Pokemon Titles unsuccessful

Added by mold over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Pokemon Colosseum
Pokemon XD: Gale of Darkness

Game ID? (right click the game in the game list, Properties, Info tab)

GC6E01
GXXE01

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

[Put MD5 Hash here]
e3f389dc5662b9f941769e370195ec90
3bc1671806cf763a8712a5d398f62ad3

What's the problem? Describe what went wrong.

[Description here]
Expected result: Using Colosseum Battle, I should be able to connect a Pokemon game with a finished game saved in a Pokemon Center to Pokemon Colosseum or Pokemon XD. The connection is attempted but never completed.

Pokemon XD Connecting to Fire Red: https://i.imgur.com/ktvZBoQ.png
Error: https://i.imgur.com/U0rtnTY.png
Pokemon Colosseum Connecting to Fire Red: https://i.imgur.com/8IfOoEo.png
Error: https://i.imgur.com/JPcmx49.png

I have so far tried:
Dolphin newest (11369 appears to not be able to link to ANY VBA-M version, interestingly - there is no evidence of any connection at all.)
Dolphin 5.0-11333
Dolphin 5.0 stable
Dolphin 4.0.2
Dolphin 4.0.0
Dolphin 4.0-6000 (might require further testing)

VBA-M/WX versions:
VBA-M 2.1.4 (newest)
VBA-M 2.0.1
VBA-M WX 2.0.0 Beta2

Settings I've tried:
Dolphin:
Background input enabled on Dolphin, using GBA link as second controller

VBA-M:
gba.bin set as bios, bios enabled, skip BIOS on boot disabled
Using Gamecube link, link at boot enabled, pause when inactive disabled.
I have also tried Cable link with no success.
I open Pokemon Sapphire (Rev 1) and on the bios, hit start+select to pause the bios
I have also tried Pokemon FireRed, a specific ROM and save file that I've traded to/from in the past using Dolphin a year or two ago.

WHAT HAPPENS:
All versions of Dolphin (except for 11369) I've tried with Gamecube link via VBA-M will show "electricity" coming from the game cable in-game, saying that it's connecting. Then, connection fails after approximately 4 seconds.

WHEN IT WORKED LAST:
Based on file edit dates, it looks like I approximately had this working 6-6-2018. I may have been using Dolphin 5.0-10607 and VBA-M WX (version unknown).

What steps will reproduce the problem?
DOLPHIN: (using Dolphin - 11333)
1. Make sure that controller 2 is set to GBA, and that background input is checked.
2. Open Pokemon Colosseum (with included GCI file below)
3. Go to "Colosseum Battle"
4. Choose "Gang Battle"
5. Choose "Battle with 2" controller vs GBA
6. Choose "Single Battle"
7. Choose "Anything Goes"
8. Hit yes

VBA-M (Using VBA-M 2.1.4)
1. Open VBA-M
2. Options > Link > Type > Gamecube
3. Options > Link > Local Mode
4. Options > Link > Link at boot
5. Options > Game Boy Advance > Use BIOS file
6. Options > Game Boy Advance > Configure > Boot ROM > Select your BIOS file
7. Emulation > UNCHECK pause when inactive
8. Emulation > UNCHECK Skip Bios
9. Open Pokemon Sapphire Rev 1.1 or Fire Red
10. Hit Start + Select on BIOS to pause it
11. File > Import > Battery File and choose the corresponding sav file
12. Keep VBAM window as focus while Dolphin attempts to connect, then fails.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Dolphin-11333 is the version I was testing mostly.

Is the issue present in the latest stable version?

Yes - 11369
However, unlike in 11333, no evidence of connection (such as in those screenshots) is seen at all.

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

Dolphin 4.0.0

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

[PC specs here]

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

1636 - Pokemon Fire Red (U)(Squirrels).sav (128 KB) 1636 - Pokemon Fire Red (U)(Squirrels).sav Fire Red Battery File mold, 12/11/2019 12:54 AM
Sapphire.sav (128 KB) Sapphire.sav Sapphire Battery File mold, 12/11/2019 12:55 AM
01-GC6E-pokemon_colosseum.gci (384 KB) 01-GC6E-pokemon_colosseum.gci Colosseum GCI File mold, 12/11/2019 12:55 AM
Dolphin.ini (8.71 KB) Dolphin.ini Dolphin config mold, 12/11/2019 12:56 AM

Related issues

Is duplicate of Emulator - Emulator Issues #7098: GBA Connectivity Master IssueAccepted

History

#1 Updated by mold over 1 year ago

Forgot to add PC specs:
Windows 10 Pro x64
NVIDIA GeForce 1080
16GB of RAM
Intel i7-8700 @ 3.20GHz

#2 Updated by mold over 1 year ago

Additionally, I also attempted a completely cleared portable config file with Dolphin 5.0-7501 just to make sure that it was not my config file conflicting with both VBAM WX 2.0.1 beta and VBAM 2.1.4 with no success.

#3 Updated by JosJuice over 1 year ago

#4 Updated by JosJuice over 1 year ago

  • Status changed from New to Duplicate

Also available in: Atom PDF