Project

General

Profile

Emulator Issues #11943

Paper Mario: The Thousand Year Door crashes after intro cutscene

Added by Liberation546 6 months ago. Updated 6 months ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Paper Mario: The Thousand Year Door

Game ID? (right click the game in the game list, Properties, Info tab)

G8ME01

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

089a0f8912bfa0a6ad8a711c0a077465

What's the problem? Describe what went wrong.

After the cutscene with the boat ends, the game crashes.

What steps will reproduce the problem?

  1. Start a new save.
  2. Watch the intro cutscene.
  3. Press A on the boat cutscene to progress it.
  4. Game crash.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes
5.0-11420 (master branch) revision 7a6a4510f6eed48652200f8c83e79723ae3581f2

Is the issue present in the latest stable version?

No
5.0

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

What are your PC specifications? (CPU, GPU, Operating System, more)

Windows 10 Pro x64 version 1903 build 18362.535
CPU: AMD A10-7860K Radeon R7, 12 Compute Cores (4C+8G), 3.60 GHz
GPU: AMD Radeon R7 Chipset
8GB RAM (~7GB usable)

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Log: https://www.dropbox.com/s/s5hsrdj4q1ih5w4/dolphin.log?dl=0
Config (Folder): https://www.dropbox.com/s/wcp3k1vyrukn50c/Config.zip?dl=0

History

#1 Updated by Techjar 6 months ago

Which graphics backend are you using?

#2 Updated by Liberation546 6 months ago

OpenGL

#3 Updated by Techjar 6 months ago

Try Direct3D, it's possible SSBO support is broken on that old APU.

#4 Updated by Techjar 6 months ago

It's also possible the issue has been fixed in a new graphics driver version, and yours is just outdated.

#5 Updated by Liberation546 6 months ago

I'm getting graphical glitches with direct3d 11 and direct3d 12. Load times are extremely long (~30s to start), save selection menu is completely broken (graphically), etc.
I have not updated my driver yet, but I'll do that now.

#6 Updated by Liberation546 6 months ago

I have updated my driver I'll try again with OpenGL, Direct3D 11 and Direct3D 12.

#7 Updated by Liberation546 6 months ago

I attempted OpenGL, Direct3D 11 and 12 and Vulkan. Vulkan was the only one that works.

Also available in: Atom PDF