Project

General

Profile

Emulator Issues #11948

Glitchy shadows in Marble Saga: Kororinpa

Added by pokechu22 about 1 year ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Marble Saga: Kororinpa

Game ID?

RK6E18

MD5 Hash?

C37E13E1B8A3A243B5FBC5FC96A83F5A

What's the problem? Describe what went wrong.

The marble's shadows are sometimes incorrect. Occasionally, the shadow is not positioned next to the ball; at other times, there are two shadows, one of which is in the wrong place. This does not happen on console (as far as I can tell, there is only supposed to be one shadow).

What steps will reproduce the problem?

Simply play the game and wait for weird shadows. It can also be seen on the demo that occurs after waiting on the title screen.

The nature of the glitchyness seems to vary based on the backend in use when recording. D3D11 and OpenGL glitch in slightly different ways (this may just be me picking up a patern out of random behavior though). All screenshots and logs were taken with D3D11. My computer is too old to use D3D12 or Vulkan with my GPU, but I was able to test D3D12 with "Microsoft Basic Render Driver" and it also happened there.

Is the issue present in the latest development version?

Tested in 5.0-11333.

Is the issue present in the latest stable version?

Yes, in 5.0.

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible.

Short 3-frame fifolog: MarbleSagaShadows2.dff

There is also a much longer 120-frame fifolog in MarbleSagaShadows.7z (some frames to look at: 13-15, 109-112). Note that for some reason the ball glass and crystal go invisible for parts of this when playing it back; that didn't happen when recording. When the glass is invisible, there is no shadow to look at.

What are your PC specifications?

  • CPU: AMD A6-340M APU with Radeon(tm) Graphics, 1500 Mhz, 4 Core(s), 4 Logical Processor(s)
  • GPU: AMD Radeon HD 6520G
  • OS: Windows 10 Pro (Insider preview) 10.10.19041.1
RK6E18_2020-01-11_11-48-58.png (489 KB) RK6E18_2020-01-11_11-48-58.png Good shadow pokechu22, 01/11/2020 07:50 PM
RK6E18_2020-01-11_11-49-02.png (498 KB) RK6E18_2020-01-11_11-49-02.png Offset shadow, one frame later pokechu22, 01/11/2020 07:50 PM
MarbleSagaShadows2.dff (4.03 MB) MarbleSagaShadows2.dff 3-frame fifolog pokechu22, 01/11/2020 07:56 PM
MarbleSagaShadows.7z (673 KB) MarbleSagaShadows.7z 120-frame fifolog pokechu22, 01/11/2020 07:56 PM
7649
7650

Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JosJuice about 1 year ago

#2 Updated by JosJuice about 1 year ago

  • Status changed from New to Duplicate

pokechu22 said on IRC that this was caused by dual core.

Also available in: Atom PDF