Project

General

Profile

Emulator Issues #11950

Cheat search can't compare against previous value anymore

Added by Yacker 5 months ago. Updated 5 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem? Describe what went wrong.

Cheat search can no longer compare against previous value

What steps will reproduce the problem?

There is no option in cheat search to compare against previous value, and using the old method of leaving the box blank will instead state "No search value entered."

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, 5.0-11452

Is the issue present in the latest stable version?

No, 5.0

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

I don't know what version exactly, but as far as I'm aware the feature has never worked in the Qt GUI. Though in older versions a blank box seems to function as 0 instead of the current behaviour. (Earliest version I have to test this with is 5.0-8535, and it's safe to assume this is how it always functioned until the new behaviour)


Related issues

Is duplicate of Emulator - Emulator Issues #11434: Unknown Value Search in Cheat Manager is Now Impossible, Empty Text Box is treated as ZeroFix pending

History

#1 Updated by JosJuice 5 months ago

  • Regression changed from No to Yes
  • Milestone set to Current
  • Status changed from New to Accepted

#2 Updated by Pikachu025 5 months ago

Duplicate of #11434

FYI, this would be fixed by https://github.com/dolphin-emu/dolphin/pull/8311

#3 Updated by JosJuice 5 months ago

  • Is duplicate of Emulator Issues #11434: Unknown Value Search in Cheat Manager is Now Impossible, Empty Text Box is treated as Zero added

#4 Updated by JosJuice 5 months ago

  • Status changed from Accepted to Duplicate

Also available in: Atom PDF