Project

General

Profile

Emulator Issues #11991

[MacOS] Vulkan is broken on latest builds

Added by jpapetti0713 about 1 month ago. Updated 24 days ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

ANY

Game ID? (right click the game in the game list, Properties, Info tab)

ANY

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

NONE

What's the problem? Describe what went wrong.

When trying to boot any title with Vulkan in latest Dolphin builds, there is nothing displayed on screen, but there is audio.

What steps will reproduce the problem?

  1. Select Vulkan
  2. Open file

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-11688

Is the issue present in the latest stable version?

No

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

5.0-11688

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

Fifo log of wii health screen attached.

What are your PC specifications? (CPU, GPU, Operating System, more)

MacBook Pro (Retina, 13-inch, Mid 2014), 2.6 GHz Intel Core i5, RAM: 16 GB 1600 MHz DDR3, Video: Intel Iris 1536 MB, running MacOS Mojave 10.14.6 (18G95).

fifowiimenu.dff (1.18 MB) fifowiimenu.dff jpapetti0713, 02/24/2020 12:38 PM
fifowiimenu.png (452 KB) fifowiimenu.png jpapetti0713, 02/24/2020 12:46 PM
7683

Related issues

Is duplicate of Emulator - Emulator Issues #12002: macOS black screen with Vulkan Backend since commit Qt/TAS Improve TAS/Windows v5.0-11688Fixed

History

#1 Updated by Stenzek about 1 month ago

Does this occur on older builds? There's a bunch of things which could be going wrong, and I don't have access to a Mac at the moment so debugging it myself is difficult.

#2 Updated by jpapetti0713 about 1 month ago

Stenzek wrote:

Does this occur on older builds?

No, 5.0-11655, 11657, 11673, 11686 11688 all work fine with Vulkan. It's just this build for some reason.

#3 Updated by jpapetti0713 about 1 month ago

Not sure if this is related, but for some reason, I can't compile Dolphin on my Mac because of code signing issues.

I was able to compile Dolphin before, but now I get this error:

CodeSign xcode/Binaries/Debug/Dolphin.app
    cd "/Users/guy/Downloads/dol"
    export CODESIGN_ALLOCATE=/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/codesign_allocate

Signing Identity:     "-"

    /usr/bin/codesign --force --sign - --entitlements /Users/guy/Downloads/dol/xcode/Source/Core/DolphinQt/dolphin-emu.build/Debug/dolphin-emu.build/Dolphin.app.xcent --timestamp=none /Users/guy/Downloads/dol/xcode/Binaries/Debug/Dolphin.app

/Users/guy/Downloads/dol/xcode/Binaries/Debug/Dolphin.app: code object is not signed at all
In subcomponent: /Users/guy/Downloads/dol/xcode/Binaries/Debug/Dolphin.app/Contents/Frameworks/libSDL2-2.0.0.dylib
Command /usr/bin/codesign failed with exit code 1

For me to fix it, I add the deep argument to codesign. However, I wonder if this causes the problem with Vulkan...

#4 Updated by Pizuz about 1 month ago

I can confirm this issue on my computer (iMac late 2012 with GeForce graphics) running macOS Catalina.

#5 Updated by Pizuz 24 days ago

This issue can be closed as well. PR 8666 just fixed it.

#6 Updated by JosJuice 24 days ago

  • Is duplicate of Emulator Issues #12002: macOS black screen with Vulkan Backend since commit Qt/TAS Improve TAS/Windows v5.0-11688 added

#7 Updated by JosJuice 24 days ago

  • Status changed from New to Duplicate

Also available in: Atom PDF