Project

General

Profile

Emulator Issues #12056

Guitar inputs not working properly on Rock Band 3 (Dolphin 5.0- 11843)

Added by xX760Xx 6 months ago. Updated about 1 month ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

[Rock Band 3]

Game ID? (right click the game in the game list, Properties, Info tab)

[SZBE69 (00010000535a4245)]

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

[2920c75820adfabcdcf7527960b8753d]

What's the problem? Describe what went wrong.

[Guitar inputs are not working properly, no matter what guitar I use. On Dolphin 5.0- 11843, Yellow and Blue are always held down, even after unplugging the guitar, rebinding controls, etc.]

What steps will reproduce the problem?

[Go into any song with a guitar controller configured, and I can guarantee that Yellow and Blue will either be permanently held down, or press Yellow will activate Blue/pressing Blue will activate Yellow.]

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

[Yes. Dolpin 5.0- 11843.]

Is the issue present in the latest stable version?

[No, it is not present in Dolphin 5.0.]

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

[Intel Core i5-9400F, NVIDIA GTX 760, Windows 10 Education]

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

[All I can really think of is just plug in a guitar controller. The issue occoured on an XInput guitar as well as a Wii guitar hooked up via a Raphnet Adapter. It was perfectly fine on the latest stable release (5.0).]

History

#1 Updated by JMC4789 6 months ago

Does Rockband 3 work with the Wii Remote Guitars? The Bluetooth Rockband guitars work for me... I'm guessing you're using the Guitar Hero controllers, but I don't have those...

#2 Updated by xX760Xx 6 months ago

JMC4789 wrote:

Does Rockband 3 work with the Wii Remote Guitars? The Bluetooth Rockband guitars work for me... I'm guessing you're using the Guitar Hero controllers, but I don't have those...

I don't own any Wii Rock Band guitars. 95% of the Guitar Hero/Rock Band community strictly use Guitar Hero controllers, as the Rock Band guitar is considered non-viable by the majority of the playerbase. Therefore, pretty much everybody who plays RB3 on this beta build is going to experience this issue and have to go back to the stable release.

#3 Updated by JMC4789 6 months ago

I'm just saying the guitars I have probably aren't viable for testing the issue. I'm not saying it's invalid or anything.

I'm trying to understand your setup and how you're configuring things, as the game supports a lot of input devices.

My main question was: Are you using emulated Wii Remotes (as in, configuring the guitar over an adapter) or connecting it to a real Wii Remote and connecting it like that?

#4 Updated by xX760Xx 6 months ago

I have the controller configuration exactly the same as I did in the latest stable release where it worked perfectly fine. Emulating the Wii's Bluetooth adapter in Dolphin and setting the extension to Guitar.

First I tried with Xbox 360 GH Guitars, and the two I tried have the issue. Second attempt was with the Raphnet Classic Controller to USB adapter, which provides a wired connection for a Wii guitar with a 1 ms response time. Same issue as Xbox 360 GH Guitars.

#5 Updated by Billiard26 5 months ago

  • Status changed from New to Questionable

I can't reproduce this. All frets work as expected with an emulated guitar extension in "Rock Band 3".
Please bisect to find the first broken version.

#6 Updated by Billiard26 3 months ago

Are you mapping the "Slider Bar"?
Please try not mapping the slider bar.

Please show a screenshot of your mappings.

#7 Updated by Billiard26 about 1 month ago

  • Status changed from Questionable to Won't fix

Can't reproduce. No response from user. Will re-open upon request.

Also available in: Atom PDF