Project

General

Profile

Emulator Issues #12057

Metroid Prime Changes screen mode when Wave Beam hits a wall

Added by lien 5 months ago. Updated 16 days ago.

Status:
Duplicate
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Metroid Prime for Gamecube

Game ID? (right click the game in the game list, Properties, Info tab)

GM8P01

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

b1379c44e0ebc521e18215de3e5dbeea

What's the problem? Describe what went wrong.

[Description here]
Screen mode changes from 4:3 to 16:9 if Wave beam is used and hits a wall

What steps will reproduce the problem?

In Phazon Mines (at least), Equip the Wave Beam and shoot a wall, the moment the beam hits the wall the video changes from 4:3 to 16:9 until start or map button is pressed. Other beams don't cause this issue. If you shoot a charged wave beam it doesn't happen either. (see the video)

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

I don't use dev version

Is the issue present in the latest stable version?

Dolphin 5.0-11845

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

You can see a video of it here:
https://drive.google.com/open?id=19TL2WLNOGpeBfWc4Pek1VAiCPjPeKhHo

What are your PC specifications? (CPU, GPU, Operating System, more)

CPU Intel Core i7-9750H
Graphics Nvidia GeForce RTX 2070
Memory 16GB DDR4-2666
SSD 1TB M.2 PCIe NVMe SSD
Windows 10

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

You can use this savestate:
https://drive.google.com/open?id=1N7apGID08DAtC1mlOLXDuN-5qxRGqopr


Related issues

Related to Emulator - Emulator Issues #12090: Metal Arms: Glitch in the System Widescreen Hack Not ApplyingDuplicate

Related to Emulator - Emulator Issues #12202: PR #8584 widescreen heuristic issuesDuplicate

Is duplicate of Emulator - Emulator Issues #12254: Widescreen Heuristic Mega-IssueAccepted

History

#1 Updated by Techjar 5 months ago

This might be a bug caused by the changes to the widescreen heuristic we just merged. "Force 4:3" should work around the issue for now, until we figure out what's going on.

#3 Updated by lien 5 months ago

Techjar wrote:

This might be a bug caused by the changes to the widescreen heuristic we just merged. "Force 4:3" should work around the issue for now, until we figure out what's going on.

Correct! forcing 4:3 workarounds the issue. Thanks!

#4 Updated by Billiard26 5 months ago

lien
Can you please produce a fifolog which showcases the transition from 4:3 to 16:9?
Your log plays entirely in just 16:9.

#5 Updated by lien 5 months ago

Billiard26 wrote:

lien
Can you please produce a fifolog which showcases the transition from 4:3 to 16:9?
Your log plays entirely in just 16:9.

@Billiard26 please check this one:
https://drive.google.com/open?id=1C1TBMIcdpYEJTE1soUqPWZAo37h7RAjx

#6 Updated by Billiard26 5 months ago

  • Assignee set to Billiard26
  • Status changed from New to Work started

Thanks. Looking into it.

#7 Updated by Billiard26 5 months ago

#8 Updated by Billiard26 2 months ago

#9 Updated by JMC4789 16 days ago

  • Status changed from Work started to Duplicate

Compiling these into a mega issue. Thank you for your report.

#10 Updated by JMC4789 16 days ago

Also available in: Atom PDF