Project

General

Profile

Emulator Issues #12089

Kirby Air Ride LOD Issue

Added by Peduls 2 months ago. Updated 2 months ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

[Kirby Air Ride]

Game ID? (right click the game in the game list, Properties, Info tab)

[GKYE01]

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

[bd936616ba7f998d8d0a1eb3f553b634]

What's the problem? Describe what went wrong.

[Certain objects in the distance are rendered improperly]

What steps will reproduce the problem?

[The issue is most noticeable in City Trial]

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

[Yes, Dolphin 5.0-12015]

Is the issue present in the latest stable version?

[No, Dolphin 5.0]

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

[Operating System
Windows 10 Enterprise 64-bit
CPU
Intel Core i7 4790K @ 4.00GHz
Haswell 22nm Technology
RAM
16.0GB Dual-Channel DDR3 @ 799MHz (9-9-9-24)
Motherboard
ASUSTeK COMPUTER INC. Z97-A (SOCKET 1150)
Graphics
VG248 (1920x1080@144Hz)
SAMSUNG (1360x768@60Hz)
4095MB NVIDIA GeForce GTX 1070 (EVGA)
Storage
465GB Samsung SSD 850 EVO 500GB (SATA (SSD))
2794GB TOSHIBA HDWD130 (SATA )
Optical Drives
ASUS DRW-24B1ST j
Audio
High Definition Audio Device]

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

[Anything else here]

GKYE01_2020-05-06_08-40-33.png (927 KB) GKYE01_2020-05-06_08-40-33.png Light shafts visible but the platform is not. Peduls, 05/06/2020 03:09 PM
GKYE01_2020-05-06_08-40-41.png (981 KB) GKYE01_2020-05-06_08-40-41.png Light shafts not visible but the platform is. Peduls, 05/06/2020 03:10 PM
7791
7792

History

#1 Updated by Peduls 2 months ago

After some more testing this only happens in multiplayer.

#2 Updated by JMC4789 2 months ago

Have you tried this on console? This seems like something that is just an actual game bug.

#3 Updated by Pikachu025 2 months ago

I'd hesitate to even call this a bug, this just looks like a render distance decision to keep the game running at a smooth framerate in multiplayer. Granted, it's more obvious at 1080p than on a CRT at 480i.

But yeah, please check this on console.

Also available in: Atom PDF