Project

General

Profile

Emulator Issues #12116

Interaction with remote desktop software related to USB gamecube adapter

Added by rmn 4 months ago. Updated 9 days ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem? Describe what went wrong.

(As best as I can tell): When another program has stolen the gamecube adapter USB device, Dolphin doesn't realize this and continues to attempt to communicate with it, causing huge amounts of error messages in the kernel log--thousands per second--until Dolphin is closed. I noticed this when in a short amount of time the log filled the entire HDD. I encountered this problem while using a remote desktop software for work (vmware-view) which attempts to rudely snatch up USB devices. Clearly it's not Dolphin's fault that another piece of software is behaving badly (and this is easy enough to work around), but is there a reasonable way for Dolphin to detect that something has gone wrong with the USB device rather than cause many GBs worth of error logs?

What steps will reproduce the problem?

Run Dolphin with a gamecube adapter connected. Start vmware horizon and connect to a remote desktop. Either have it configured to auto-connect to USB (initially discovered this way), or after loading select the gamecube adapter from the "Connect USB Device" menu (investigated what was happening by doing this).

I have not tested this on Windows or with other virtual machine or remote desktop software that might attempt to take control of USB devices.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes. Tested on 5.0-12058.

Is the issue present in the latest stable version?

I'm not sure. Having trouble compiling 5.0 stable. I know it happens on at least 5.0-10836, which is the version on which I originally encountered the problem.

If the issue isn't present in the latest stable version, which is the first broken version?

Was not able to test 5.0 stable to see about this.

What are your PC specifications? (CPU, GPU, Operating System, more)

MSI laptop running Debian Buster. Kernel version 4.19.0-9-amd64. Intel i5-4210H. Nvidia card present but running Dolphin on integrated graphics. libusb-1.0-0 version 2:1.0.22-2.

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Sample of kernel log (this message is repeated roughly 10000 times per second once the problem is triggered and continues until Dolphin is closed):
May 22 13:10:11 rmn-msi kernel: [11649.917787] usb 2-1: usbfs: process 10620 (GC Adapter Scan) did not claim interface 0 before use
May 22 13:10:11 rmn-msi kernel: [11649.917816] usb 2-1: usbfs: process 10620 (GC Adapter Scan) did not claim interface 0 before use

Sample of output when running Dolphin with LIBUSB_DEBUG=4:
[13.104760] [0000297c] libusb: debug [libusb_free_transfer] transfer 0x7ffa08001330
[13.104769] [0000297c] libusb: debug [libusb_alloc_transfer] transfer 0x7ffa08001330
[13.104776] [0000297c] libusb: debug [libusb_submit_transfer] transfer 0x7ffa08001330
[13.104783] [0000297c] libusb: debug [add_to_flying_list] arm timerfd for timeout in 16ms (first in line)
[13.104792] [0000297c] libusb: debug [submit_bulk_transfer] need 1 urbs for new transfer with length 37
[13.104801] [0000297c] libusb: error [submit_bulk_transfer] submiturb failed error -1 errno=16
[13.104809] [0000297c] libusb: debug [submit_bulk_transfer] first URB failed, easy peasy
[13.104816] [0000297c] libusb: debug [disarm_timerfd]
[13.104824] [0000297c] libusb: debug [libusb_free_transfer] transfer 0x7ffa08001330
[13.104833] [0000297c] libusb: debug [libusb_alloc_transfer] transfer 0x7ffa08001330
[13.104840] [0000297c] libusb: debug [libusb_submit_transfer] transfer 0x7ffa08001330
[13.104848] [0000297c] libusb: debug [add_to_flying_list] arm timerfd for timeout in 16ms (first in line)
[13.104906] [0000297c] libusb: debug [submit_bulk_transfer] need 1 urbs for new transfer with length 37
[13.104917] [0000297c] libusb: error [submit_bulk_transfer] submiturb failed error -1 errno=16
[13.104925] [0000297c] libusb: debug [submit_bulk_transfer] first URB failed, easy peasy
[13.104932] [0000297c] libusb: debug [disarm_timerfd]


Related issues

Is duplicate of Emulator - Emulator Issues #10408: Mayflash GameCube Controller Adapter doesn't work over usbipFix pending

History

#1 Updated by Billiard26 9 days ago

#2 Updated by Billiard26 9 days ago

  • Status changed from New to Duplicate

Also available in: Atom PDF