Project

General

Profile

Emulator Issues #12129

Dolphin does not save Pikmin 2 data to the memory card

Added by Shrekacito 4 months ago. Updated 16 days ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

[Pikmin 2]

Game ID? (right click the game in the game list, Properties, Info tab)

[GPVE01]

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

[66f8d886afa0742cd9901d1bfe3b114f]

What's the problem? Describe what went wrong.

[Dolphin fails to save the memory card data of Pikmin 2. I have tested Pikmin 1, and it does save to the memory card. I have made sure that the memory card in slot A has been assigned to my card file, and it has. I have tried saving Pikmin 2 twice, and both times it did not save. I made another save and checked in the memory card manager if my Pikmin 2 save was on the card, and sure enough, it was. But when I saved the game and stopped the emulation, It mysteriously was deleted. I don't want to have to resort to saving with savestates, because I already have had to witness accidentally saving after coming back to play an NES game in the morning on NES emulators.]

What steps will reproduce the problem?

[Make a save file for Pikmin 2, play until it asks you to save, then turn off the emulation after you have saved, (Optional: go to bed and in the morning wake up to play pikmin 2.) then try to load your nonexistant save.]

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

[Don't know]

Is the issue present in the latest stable version?

[Dolphin 5.0-12088 (Windows) ]

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[Not sure]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Not a graphical issue]

What are your PC specifications? (CPU, GPU, Operating System, more)

[Dell Inspiron 15-5559 Laptop Intel i3-6300U@2.30GHz, Intel HD integrated graphics 520 Windows 10, 16GB DDR3L SODIMM, wdc wd10jpvx-75jc3t0 HDD]

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

[Not sure]

History

#1 Updated by Techjar 4 months ago

To be clear, you are using memory card not GCI folder, correct?

#2 Updated by JMC4789 4 months ago

We're going to need very exact instructions on how to reproduce this issue. It does not sound like something that should be possible. I have ancient Pikmin 2 saves on both memory cards and GCI folders that have never gotten deleted, and this has never been mentioned by anyone in the past. Either this is an extreme edge-case or some kind of user error.

#3 Updated by Shrekacito 4 months ago

Techjar wrote:

To be clear, you are using memory card not GCI folder, correct?

I was trying to save my save data into a directory like this: Documents\Dolphin Emulator\GC\MemoryCardA.raw
My MemoryCardA.raw has like 3 other savegames on it, none of which mysteriously disappeared.

#4 Updated by Billiard26 2 months ago

Perhaps your memory card file is corrupt?
Can you attach it?

#5 Updated by JMC4789 16 days ago

  • Status changed from New to Invalid

No response. Also I did a quick save in Pikmin 2 just now and it was indeed there on my memory card. I also tried it on GCI folder, and it also saved there.

In order to reproduce an issue where dolphin didn't save, it's incredibly important to provide us with exact steps so that we can reproduce your issue. A game not saving like this is strange and no one else has reported it, meaning that if it was somehow Dolphin's fault, it was a very strange incident.

Also available in: Atom PDF