Project

General

Profile

Emulator Issues #12158

Dolphin crashes while extracting game files

Added by Bussun 26 days ago. Updated 2 days ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
5.0-11871
Fixed in:
5.0-12280

Description

Game Name?
Super Mario Galaxy

Game ID? (right click the game in the game list, Properties, Info tab)
RMGP01

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)
a8c962d1922f7521dc4b07348e4e8a51

What's the problem? Describe what went wrong.

When I try to extract the game files (I use the extract entire disc option), dolphin closes itself in the middle of the process without any error message.

What steps will reproduce the problem?

1.Open Dolphin
2.Add the iso location in Config -> Paths
3.Open the properties by right-clicking on the game
4.Go to the Filesystem tab
5.Right-clicking on Disc and selecting "Extract Entire Disc"
6.Wait

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, it's the 5.0-12145 build at the time of writing.

Is the issue present in the latest stable version?

No, this bug didn't exist in the 5.0 release.

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

It has been broken since the 5.0-11871 build.

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

It isn't a graphical issue.

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel Core i3-8145U
iGPU (the UHD 620)
Windows 10 Home 2004

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Using space-free paths doesn't solve the problem. The game has been dumped several times using CleanRip.


Related issues

Related to Emulator - Emulator Issues #12180: Crash when decompressing gcz onto NASFixed

History

#1 Updated by flacs 26 days ago

  • Regression start set to 5.0-11871
  • Regression changed from No to Yes

#2 Updated by JosJuice 26 days ago

I can't reproduce this, using Windows 10 (version 1903) and the exact same disc image. Perhaps it's some kind of race condition that I happen to not run into?

#3 Updated by Bussun 25 days ago

Odd, I don't know what could be different on my computer. I tried on another computer with Windows 10 1909 and a newly downloaded build of dolphin but still the same issue. It's maybe related to my dump idk. The Verify tab tells me that my dump is "fine" so I don't know.

#4 Updated by JosJuice 25 days ago

My dump has the exact same MD5, so I don't think it's that.

#5 Updated by MrMrMANGOMILK 21 days ago

Same issue with Mario Kart Wii. Specific files extract just fine but the Extract Entire Disc option fails partway through and kills Dolphin. Was previously on Win10 1909, I've upgraded to 2004 and haven't tested on this version

AMD Ryzen 5 3600
Nvidia GTX 980 SC

#6 Updated by JosJuice 4 days ago

#8 Updated by JosJuice 4 days ago

  • Fixed in set to 5.0-12280
  • Status changed from New to Fixed

This has been confirmed to fix the same issue for other progress dialogs for at least two other people, so I'm marking the issue as fixed. Please leave a comment if it still isn't working.

https://dolphin-emu.org/download/dev/5281efe2686f947195f7044b56eca00c7b7527a1/

#9 Updated by 13xforever 4 days ago

Although the crash was fixed, there is still an issue with this specific dialog.
After the compression/decompression is finished, progress dialog reappears again, flashing, and preventing any input.

(seizure warning) https://cdn.discordapp.com/attachments/485204327800242177/730747094851256350/GIF.gif

#10 Updated by Bussun 4 days ago

The issue I described at first is indeed fixed, but I have the same new issue as 13xforever, the window reappers and flashes.

#12 Updated by Miksel12 3 days ago

That build fixed the issue for me.

#13 Updated by okamiterasu 3 days ago

JosJuice wrote:

Please test this new build: https://dl.dolphin-emu.org/prs/fc/5a/pr-8945-dolphin-latest-x64.7z

Also fixes for me

#14 Updated by Bussun 3 days ago

JosJuice wrote:

Please test this new build: https://dl.dolphin-emu.org/prs/fc/5a/pr-8945-dolphin-latest-x64.7z

Perfect. Fixed for me as well.

#15 Updated by JosJuice 2 days ago

Merged as 5.0-12282.

Also available in: Atom PDF