Project

General

Profile

Emulator Issues #12213

Career mode crashes my entire computer

Added by Eleven 13 days ago. Updated 6 days ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

ATV Quad Power Racing 2

Game ID? (right click the game in the game list, Properties, Info tab)

GATE51

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

4712e192117bee2d53fc8ec7577f0a38

What's the problem? Describe what went wrong.

When rounding a certain turn (the fourth checkpoint), or perhaps its a time related issue the game freezes, then the music cuts back in for a moment, my entire screen goes black, the music stops and then my dolphin window is corrupted with the visuals becoming almost entirely green and shades of violet. I managed to open my window manager once before the full crash, and every windows had this corrupted look. No inputs work after the game freezes at first, there is no way to close dolphin in time once it starts. The only way to fix it via the power button.

What steps will reproduce the problem?

I'm not entirely sure what the cause is, but I'll explain what I did. I started a new profile with the Chuck Miller character, named "GO", then I go straight to career mode, choosing Amateur, since its the only one unlocked, I choose any of the three unlocked atvs and start the first race. The very beginning has some lag, but the game runs fine up to the fourth checkpoint, where it does the above.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, 5.0-12367

Is the issue present in the latest stable version?

Yes, 5.0 (the issue was slightly different, crashing just after the first checkpoint)

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

CPU: Ryzen 5 2600
GPU: MSI Radeon RX 570 8 gb Armor
OS: Ubuntu 20.04
RAM: 16 GB DDR4 2400MHz

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

I have included my save file.

51-GATE-PROFILESPROFILE.gci (72.1 KB) 51-GATE-PROFILESPROFILE.gci My save Eleven, 08/02/2020 02:13 AM

History

#1 Updated by Eleven 13 days ago

Also I am using OpenGL forgot to mention that, although I don't think changing it has any effect..

#2 Updated by JMC4789 13 days ago

If your entire computer is crashing, it is a fault outside of Dolphin. Dolphin is a usermode program that is unable to cause your whole computer to crash. The most likely culprit would be your graphics drivers, as they are kernel level.

#3 Updated by Billiard26 6 days ago

  • Status changed from New to Invalid

Like JMC said. If your computer is crashing it is out of Dolphin's control.

Also available in: Atom PDF