Project

General

Profile

Emulator Issues #12216

[Feature Request] Precache entire game into RAM

Added by TzakShrike 3 months ago. Updated 3 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Feature request
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Please add an option to preload the entire game into RAM before launching it.
Extra points for the ability to launch the game near instantly, but then caching the entire game into RAM as early as possible.


Related issues

Is duplicate of Emulator - Emulator Issues #11876: [Feature Request] Load game into RAMNew

History

#1 Updated by Techjar 3 months ago

Might I ask why?

#2 Updated by MayImilae 3 months ago

  • Issue type changed from Bug to Feature request
  • Status changed from New to Questionable

Did you know that any hard drive is faster than the GameCube or Wii's disc drive? Even crappy old 5400RPM drives are faster than a DVD drive! Since Dolphin emulates the loading of the optical disc drive, even a middle of the road SD card should be fast enough to meet the required speeds without imparting any slowdown. Late 90s optical technology is extremely slow by modern standards!

If you want a tremendous speedup in load times in Dolphin right now, all you need to do is right click the game in the game list, click properties, then enable "Speed up disc transfer rate". This disables our disc drive speed limits so Dolphin will load the game as fast as your computer can fetch data from the emulated disc. This will TREMENDOUSLY speed up loading times, ram caching not required. However please be aware that this can cause some bugs in some games, and will block netplay and TAS compatibility since it makes loading nondeterministic.

Anyway, as for this feature request... eh. I won't close it since we could, but it is pretty pointless. Once emulated drive speed limits are disabled, is 24000MBps better than 3000MBps when a few megabytes of data at a time? Does that really matter when it is completely impossible for a human to tell the extra couple of milliseconds it might take?

#3 Updated by Techjar 3 months ago

Big emphasis on "can cause some bugs", as I have absolutely had several games freeze or crash in loading screens when Fast Disc Speed is enabled.

#4 Updated by JosJuice 3 months ago

#5 Updated by JosJuice 3 months ago

  • Status changed from Questionable to Duplicate

#6 Updated by JosJuice 3 months ago

Speed Up Disc Transfer Rate is actually deterministic. However, this gives it a different problem: If the hard drive can't keep up with the now zero-latency emulated disc drive (which it probably can't), the performance will stutter.

Also available in: Atom PDF