Project

General

Profile

Emulator Issues #12226

Dolphin fails to build when an old version of zstd is installed

Added by stormy178 about 1 month ago. Updated about 1 month ago.

Status:
Fix pending
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
5.0-12188
Fixed in:

Description

What's the problem? Describe what went wrong.

Dolphin fails to build when using sudo make install.

What steps will reproduce the problem?

Downloaded the source code into a set folder, made and changed to build directory,
Then proceeded to use cmake .., then...
used sudo make install.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Github source code, commit 4a34b74e6882a20edbcf2399dc8f9b397e62d82a

Is the issue present in the latest stable version?

N/a (unknown)

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

What are your PC specifications? (CPU, GPU, Operating System, more)

PC build specs as set in PC Part picker. https://pcpartpicker.com/user/Stormy178/saved/#view=yvNZf7 Currently running Debian Buster(10)
v4.19.0-10 at time of posting

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Link to the pastebin log. https://pastebin.com/ufuwEkK5

History

#2 Updated by stormy178 about 1 month ago

Alright, thank you. Took me a while to update the required libraries, but now it's working and installed.
This can now be closed.

#3 Updated by JosJuice about 1 month ago

  • Regression start set to 5.0-12188
  • Regression changed from No to Yes
  • Milestone set to Current
  • Status changed from New to Fix pending
  • Subject changed from Dolphin Linux Build Error to Dolphin fails to build when an old version of zstd is installed

This is something that should be fixed on Dolphin's side, so I will keep the issue open. Fixed in PR: https://github.com/dolphin-emu/dolphin/pull/8917

Also available in: Atom PDF