Project

General

Profile

Emulator Issues #12247

Kirby Air Ride on Android: Black Textures

Added by Wumbo 7 months ago. Updated 7 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
5.0-10758
Fixed in:

Description

Kirby Air Ride

Game ID: GYKEO1

MD5 Hash:

bd936616ba7f998d8d0a1eb3f553b634

What's the problem?

On the android version of Dolphin.
When running the game and trying to play either air ride or city trial mode the textures fail to load. This makes most of the screen black with empty textures.

What steps will reproduce the problem?

[Reproduction steps here]

My device: Galaxy Note 9: Snapdragon 845.

Upon upgrading from Dolphin (Android)
version 5.0-10756
to
Version 5.0-10758

The textures no longer properly load. Launching the game and playing either Air ride or City trial mode reproduces the effect.

[Version number here]
Last working version: 5.0-10756
First non-working version: 5.0-10758

Is the issue present in the latest stable version?
Yes

[Yes/No and version number here]
Yes, still NOT working on current stable
Version 5.0-12247

[First broken version number here (if applicable)]

5.0-10758

**If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible.
See attachment(s)

What are your PC specifications? (CPU, GPU, Operating System, more)

[Android specs here]

Galaxy Note 9: Snapdragon 845, Android 10 OS

Potentially similar to known issue on Mac and pc's (Windows) found here:

https://bugs.dolphin-emu.org/issues/11817


Related issues

Related to Emulator - Emulator Issues #11817: Kirby Air Ride unplayable with Vulkan on macOSDuplicate

Is duplicate of Emulator - Emulator Issues #11843: Devices without LogicOps support render environment textures in Air Ride and City Trial as blackAccepted

History

#1 Updated by JosJuice 7 months ago

#2 Updated by JosJuice 7 months ago

  • Regression start set to 5.0-10758
  • Regression changed from No to Yes
  • Assignee set to Stenzek

#4 Updated by JosJuice 7 months ago

Drivers that support logic ops would indeed fix it, but what's interesting is that it was broken by the change that intended to make things better for drivers that don't.

#5 Updated by Wumbo 7 months ago

I downloaded the source code today 9/7/2020 (I believe version 5.0-12546) and commented out the changes that were added in 5.0-10758.

After building and running the modified apk the issue was fixed but, I don't know if that is a good solution. It's my first time looking at the code and I am unaware how important the void BlendingState::ApproximateLogicOpWithBlending() function is! Thanks for the awesome work guys!

#6 Updated by JMC4789 7 months ago

  • Status changed from New to Duplicate

#7 Updated by JMC4789 7 months ago

  • Is duplicate of Emulator Issues #11843: Devices without LogicOps support render environment textures in Air Ride and City Trial as black added

Also available in: Atom PDF