Project

General

Profile

Emulator Issues #12249

X-Men Legends II: Rise of Apocalypse crash at startup

Added by TheCrach 19 days ago. Updated 17 days ago.

Status:
Accepted
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

X-Men Legends II: Rise of Apocalypse

Game ID?

GX2E52

MD5 Hash?

b7b01496bf643bd150ce05e6a4786317

What's the problem? Describe what went wrong.

When first launching the game I get a Question window with the following information

GFX FIFO: Unknown opcode (0xff @ 0000024EB42C08A4, preprocess=false).
This means one of the following:
*The emulated GPU got desynced, disabling dual core can help
*Command stream corrupted by some spurious memory bug
*This really is an unknown opcode (unlikely)
*Some other sort of bug

Further errors will now be sent to the Video Backend log and
Dolphin will now crash or hang, Enjoy.

What steps will reproduce the problem?

launch the game using any Video Backend

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, 5.0-12546

Is the issue present in the latest stable version?

No

Can't use bisection tool as the thread says it's broken.

What are your PC specifications? (CPU, GPU, Operating System, more)

i5-7600 @ 3.80 GHz
GTX 1060
16GB RAM
Windows 10

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Capture.PNG (47.3 KB) Capture.PNG TheCrach, 09/08/2020 10:02 PM
7972

History

#1 Updated by TheCrach 19 days ago

7972

Screenshot

#2 Updated by TheCrach 19 days ago

All Dolphin settings are default.

#3 Updated by Techjar 19 days ago

Try disabling dual core.

#4 Updated by JMC4789 19 days ago

Just hit okay to both popups and the game will boot as per normal. This is a GPU emulation bug on startup that afflicts quite a few games.

#5 Updated by JMC4789 17 days ago

  • Status changed from New to Accepted

So, this is "GPU timing" issues to the point where I want to combine it with the dualcore timing issues, but this one technically happens in single core like F-Zero GX and Super Monkey Ball. So I don't know. It'll get fixed if someone fixes our GPU timings.

Also available in: Atom PDF