Project

General

Profile

Emulator Issues #12305

Graphical Bug

Added by JHstrutton about 1 month ago. Updated 12 days ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

[Put Game Name here]
Super Mario Sunshine

Game ID? (right click the game in the game list, Properties, Info tab)

[Put Game ID here]
GMSE01

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

[Put MD5 Hash here]
0c6d2edae9fdf40dfc410ff1623e4119

What's the problem? Describe what went wrong.

[Description here]
I don't know exactly which version of Dolphin this problem started but on the newest build (5.0-12716) Beta Version and in super Mario sunshine there is a sort of weird heat wave around everything during gameplay, this bug is not present in the stable (5.0) version. I am planning on including images from both versions.

What steps will reproduce the problem?

[Reproduction steps here]
Run Super Mario sunshine in build 5.0-12716 and get to delphine plaza (The Main Island). For some reason the first stage of the game where the plane lands does not seem to have this bug.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

[Version number here]
5.0-12716

Is the issue present in the latest stable version?

[Yes/No and version number here]
No

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]
I do not know, The only two I tested was the stable and latest versions. (5.0-12716)

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

[PC specs here]
Ryzen 7 3700x
32GB Ram 3200 Mhz
Nvidia Geforce GTX 1650

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

[Anything else here]
I attached several images

ABug.png (378 KB) ABug.png JHstrutton, 10/26/2020 12:59 AM
ANormal.png (429 KB) ANormal.png JHstrutton, 10/26/2020 12:59 AM
BNormal.png (1.25 MB) BNormal.png JHstrutton, 10/26/2020 12:59 AM
BBug.png (1.26 MB) BBug.png JHstrutton, 10/26/2020 12:59 AM
CBug.png (1.02 MB) CBug.png JHstrutton, 10/26/2020 12:59 AM
CNormal.png (1020 KB) CNormal.png JHstrutton, 10/26/2020 12:59 AM
DBug.png (1.42 MB) DBug.png JHstrutton, 10/26/2020 12:59 AM
DNormal.png (1.47 MB) DNormal.png JHstrutton, 10/26/2020 12:59 AM
Capture1.PNG (9.48 KB) Capture1.PNG JHstrutton, 10/26/2020 01:49 AM
Capture3.PNG (16 KB) Capture3.PNG JHstrutton, 10/26/2020 01:57 AM
Capture2.PNG (15.5 KB) Capture2.PNG JHstrutton, 10/26/2020 01:57 AM
Capture4.PNG (16.1 KB) Capture4.PNG JHstrutton, 10/26/2020 01:57 AM
Capture5.PNG (19 KB) Capture5.PNG JHstrutton, 10/26/2020 01:57 AM
Capture7.PNG (15.9 KB) Capture7.PNG JHstrutton, 10/26/2020 01:57 AM
Capture8.PNG (29.7 KB) Capture8.PNG JHstrutton, 10/26/2020 01:57 AM
Capture9.PNG (5.25 KB) Capture9.PNG JHstrutton, 10/26/2020 01:58 AM
8059
8060
8061
8062
8063
8064
8065
8066
8067
8068
8069
8070
8071
8072
8073
8074

History

#1 Updated by Miksel12 about 1 month ago

Are you sure you don't have any cheats enabled? I don't have the same issue.

#2 Updated by JHstrutton about 1 month ago

8067
8068
8069
8070
8071
8072
8073
8074

I did, But I just disabled them and retested it. Also made sure to turn off graphics mods and other things. I attached pictures of every setting that I could think of that could be affecting it.

I obtained my copy of the game from dumping it from the disk using my wii, As I am typing this I am redumping and testing the ISO. And the problem is still there.

#3 Updated by JMC4789 about 1 month ago

The aspect ratio appears to be modified? Do you have freelook on maybe and have accidentally moved the camera from its default position?

#4 Updated by JHstrutton about 1 month ago

The ratio is different because while I was taking the screenshots I had the aspect ratio set to "Stretch to window", and a few of the first screenshots were taken while I was not in full-screen mode.

#5 Updated by Techjar about 1 month ago

Just to rule out any configuration issue, run Dolphin in portable.txt mode to get a fresh config.

#6 Updated by JHstrutton about 1 month ago

That fixed it, Thank you very much. Apologies for making you guys run around for a bug that didn't exist.

#7 Updated by JMC4789 about 1 month ago

It'd be nice to know what setting caused it. That way we can note it on the wiki or maybe set a default in the INI that prevents that setting from hurting things.

#8 Updated by Billiard26 12 days ago

  • Status changed from New to Invalid

Also available in: Atom PDF