Project

General

Profile

Emulator Issues #12315

Cubeb won't render audio if audio is Switched to Dualchock 4 controller

Added by dragushell 22 days ago. Updated 22 days ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

[ALL GAMES]

[ALL GAME ID's]

[MD5 HASH not applicable]

What's the problem? Describe what went wrong.

[Cubeb won't render any audio if audio is switched to DS4 controller with earphones plugged in, renders fine otherwise. Workaround in 5.0 10947 due to it being the last version that included Xaudio2 plugin which worked fine. Wasapi exclusive mode if switched to controller will return black screen. Please refer to this thread for additional info https://forums.dolphin-emu.org/Thread-friendly-request-to-devs ]

What steps will reproduce the problem?

[Connect a Dualshock 4 Controller through USB , plug Headsets into controller, Switch audio to Headset earphone (Wireless Controller) in Windows, verify that the sound is working in Windows or any other app or x86 game, Boot Dolphin 5.0-12964 on Windows 10 with default settings, Go to options-audio setting and make sure Cubeb is selected as default audio Backend, Boot any game in Dolphin, ]

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

[5.0 12964 YES]

Is the issue present in the latest stable version?

[Yes if we refer to the latest beta! No, if we refer to 5.0 from 4 years ago ]

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[5.0-10950 ]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[N/A]

What are your PC specifications? (CPU, GPU, Operating System, more)

[AMD DX 8370, R9 390, windows 10 v2004]

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

[Anything else here]

History

#1 Updated by JosJuice 22 days ago

  • Regression changed from No to Yes
  • Milestone set to Current

Marking as a regression since this worked on the removed XAudio backend.

#2 Updated by Billiard26 22 days ago

I'll summarize the forum thread.

Someone confirmed this is caused by the device only supporting mono output.
They said Firefox does work (which uses cubeb).
The only relevant difference I saw between Firefox's and our code was the version of cubeb.

We might just need to update Cubeb in Externals.

#3 Updated by filoppi 22 days ago

There is a PR already:
https://github.com/dolphin-emu/dolphin/pull/8920
Now slightly outdated but might be worth testing already (the PR is complete from my side).

Also available in: Atom PDF