Project

General

Profile

Emulator Issues #12322

Real Wiimote delay when below 100% speed

Added by Suprnova123 17 days ago. Updated 6 days ago.

Status:
New
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem? Describe what went wrong.

Real Wiimote inputs gradually increase in delay if the emulator is running under 100% speed. The delay will gradually decrease and eventually return to normal when the emulation speed is at 100% or higher.

What steps will reproduce the problem?
Connect a real Wiimote as a controller, open any Wii game, and configure the emulation speed to be below 100%.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, Dolphin 5.0-12997.

Is the issue present in the latest stable version?

No.

If the issue isn't present in the latest stable version, which is the first broken version?

Dolphin 5.0-12902, broken by PR #9098

What are your PC specifications? (CPU, GPU, Operating System, more)

AMD Ryzen 5 1500x, GTX 1050TI, Windows 10 Insider Build, Mayflash Dolphinbar

History

#1 Updated by Billiard26 6 days ago

  • Assignee set to Billiard26

If games are running below 50% speed I can see how the Bluetooth report buffer will fill faster than it is emptied, but this shouldn't happen at e.g. 95% speed.
Regardless some logic could probably be tweaked to prevent the buffer from filling up.

Also available in: Atom PDF