Project

General

Profile

Emulator Issues #12325

"Configure Input" list is incorrect if main input device is not connected

Added by v1993 6 days ago. Updated 6 days ago.

Status:
Accepted
Priority:
Low
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Not game specific

What's the problem? Describe what went wrong.

See how to reproduce.

What steps will reproduce the problem?

  1. Open controller configuration window, both GC and Emulated Wii Remote will do.
  2. Select some disconnectable device in "Device" dropdown.
  3. Disconnect that device, so now it says "[disconnected] "
  4. Right-click any input field to open "Configure Input" window (advanced input configuration)
  5. In this window, device dropdown will show first device connected to the system while available inputs list will be empty (screenshot attached)
  6. Selecting another device in dropdown and the first one shows inputs correctly

I think that there are two possible ways to solve this:

  1. Show "[disconnected] " in "Configure Input" window as default selection with no options
  2. Load correct input options for first device

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-13033, Revision: 17da28ff07d1a98aaaac0fe212804a5e90125b27

Is the issue present in the latest stable version?

Unknown, but probably yes

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

Don't seem important for this issue

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

[Anything else here]

Screenshot_20201121_172948.png (67.1 KB) Screenshot_20201121_172948.png Screenshot showing the problem v1993, 11/21/2020 02:29 PM
8095

History

#1 Updated by Billiard26 6 days ago

  • Priority changed from Normal to Low
  • Status changed from New to Accepted

Also available in: Atom PDF