Project

General

Profile

Emulator Issues #12326

Internet Channel freezes on some websites

Added by TheDude53 5 months ago. Updated 4 months ago.

Status:
Questionable
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Internet Channel

Game ID? (right click the game in the game list, Properties, Info tab)

HADE01

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

762f8cd10a21f6c20f0e8895bde902bc

What's the problem? Describe what went wrong.

Browsing to some websites (Google, etc.) on the Internet Channel freeze the Wii, forcing the user to manually force turn it off. I tried overriding the CPU and RAM just in case, however this did not make any difference.

What steps will reproduce the problem?

  1. Go to the Internet Channel
  2. Go to Google
  3. Enter in any query, and search for it.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, 5.0-13129.

Is the issue present in the latest stable version?

Yes, 5.0

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

N/A

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

N/A

What are your PC specifications? (CPU, GPU, Operating System, more)

CPU: Intel Celeron N3050
GPU: Intel HD Graphics (Braswell)
OS: Windows 10 Home 64bit

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

When the Wii freezes, the logs are flooded with Core\IOS\USB\Bluetooth\BTEmu.cpp:355 E[IOS_WIIMOTE]: ACL queue size reached 100 - current packet will be dropped!

Dolphin.ini (4 KB) Dolphin.ini TheDude53, 12/05/2020 10:48 AM
dolphin.log (35 KB) dolphin.log TheDude53, 12/07/2020 05:16 PM
dolphin.log (99.7 KB) dolphin.log Full log + HLE/OSReport sepalani, 12/08/2020 05:12 PM

History

#1 Updated by JMC4789 5 months ago

  • Status changed from New to Questionable

Have you tried out the browser on console. I feel like there's a good chance it doesn't work on Google anymore. The log message is just from the channel crashing.

#2 Updated by TheDude53 5 months ago

I haven't tested it on a physical Wii however I have seen other people do it successfully.

#3 Updated by MayImilae 5 months ago

You are using a web browser from 2006 (specifically Opera 9) on the modern internet. Good luck.

Also extremely unlikely that this is our fault. Try this on console, and if it works there and not in Dolphin you'll have our attention.

#4 Updated by TheDude53 5 months ago

I can't currently test it on my personal console, however this video clip does show Google and Twitter working on a real Wii. I did test Google on the Windows version of Opera 9.00 though, and it was in a usable state.

#5 Updated by JosJuice 5 months ago

  • Status changed from Questionable to New

I tested this on my Wii just now, and Google works.

#6 Updated by sepalani 4 months ago

I can't reproduce the issue with the specified Dolphin build nor the latest dev build.

Can you provide more details regarding your configuration of Dolphin? Do you use emulated wii remote? Do you use a real Wii NAND?

#7 Updated by TheDude53 4 months ago

Interestingly, the issue does seem to reproduce (for me at least) on the latest dev build, which is 5.0-13178 as of writing.

To answer your questions, yes the Wii remote is emulated, and I have tested with both a real Wii NAND and a Dolphin-generated NAND.

If it helps, I have attached a copy of my Dolphin.ini file, which should provide further configuration details.

#8 Updated by sepalani 4 months ago

I still can't reproduce it, even with your Dolphin.ini, even with a clean portable install of Dolphin.

Can you create a portable install of Dolphin and see if you can reproduce the issue?
On Windows, you just need to create a file named "portable.txt" in the folder where the Dolphin executable is located.

Otherwise, could you provide the log file when it happens.
You'll need to:

  • Enable the Debugging UI in Config > Interface
  • In the Log Configuration view, tick Write to File in Logger Outputs
  • Set the verbosity level to info.
  • At least enable the following log types: IOS, IOS_NET, IOS_SSL, IOS_WC24, MASTER, OSHLE, OSREPORT

By the way, I tried the following version of the Opera channel v257 and v1024 on an european system menu.
I also tried the US version of the channel (still on the european system menu) without an issue.

#9 Updated by TheDude53 4 months ago

The issue still reproduces for me, even with a clean portable install of Dolphin 5.0-13184. Here is the log file as requested.

I have not yet tested on a different System Menu than 4.3U.

#10 Updated by sepalani 4 months ago

I managed to reproduce the crash, it only affects a very old version of the channel (HADE01 v3). I attached more log for future references.
I wonder if this channel works properly on a real Wii with a recent System Menu.

Regardless, it shouldn't crash Dolphin. It only crashes Dolphin when MMU is OFF. It happens with and without Dual Core mode.

The first invalid read seems to come from OSWakeupThread, some other invalid writes too.
The other addresses don't match functions in my signature database.

#11 Updated by TheDude53 4 months ago

I was not aware my WAD copy was outdated. After redownloading v1024 it does work as intended.

Given the affected channel version, would this be considered a lower priority issue?

#12 Updated by JosJuice 4 months ago

  • Status changed from New to Questionable

I will have to mark this as questionable again since nobody has verified that that specific version doesn't crash on console.

Also available in: Atom PDF