Project

General

Profile

Emulator Issues #12332

Zen 3 is capable of using PDEP/PEXT without emulation through microcode

Added by raiton 3 months ago. Updated 3 months ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Reference: https://de.dolphin-emu.org/download/dev/master/5.0-11590/

This PR shows that PDEP/PEXT is disabled for AMD Zen because it's not supported nativley.

This is not the case anymore according to the developer documenation for Zen3 processors:

"The AMD family 19h processor has native ALU support for PDEP/PEXT, so one such instruction can
be sustained per cycle, with a three-cycle latency for producing the result. Software that uses different
codepaths for processors with fast and slow PDEP/PEXT instructions should choose the fast
PDEP/PEXT codepath for family 19h processors." (Page 40, 2.10.2 Execution Units)

https://developer.amd.com/resources/developer-guides-manuals/ (Software Optimization Guide for AMD Family 19h Processors (PUB))

My question is did this PR also disable PDEP/PEXT for Zen3 family?

History

#1 Updated by leoetlino 3 months ago

  • Status changed from New to Invalid

Also available in: Atom PDF