Project

General

Profile

Actions

Emulator Issues #12362

closed

DSU input causes error in input expression editor due to space in names of inputs

Added by v1993 about 3 years ago. Updated almost 3 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:
5.0-13549

Description

Game Name?
Game ID? (right click the game in the game list, Properties, Info tab)
MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)
What's the problem? Describe what went wrong.

DSU inputs give error in expression editor due to space in their name.

What steps will reproduce the problem?

Configure DSU client motion input as "default", then right click any of accel/gyro inputs.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes

Is the issue present in the latest stable version?

Dunno

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

What are your PC specifications? (CPU, GPU, Operating System, more)

KUbuntu 20.10

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Sure, screenshot of error attached.


Files

Screenshot_20201227_165945.png (55.9 KB) Screenshot_20201227_165945.png v1993, 12/27/2020 02:00 PM
Actions #1

Updated by Billiard26 about 3 years ago

  • Status changed from New to Fix pending
Actions #2

Updated by v1993 almost 3 years ago

Billiard26 wrote:

https://github.com/dolphin-emu/dolphin/pull/9416

It have been merged. Should this be closed as Fixed?

Actions #3

Updated by JosJuice almost 3 years ago

  • Status changed from Fix pending to Fixed
  • Fixed in set to 5.0-13549
Actions

Also available in: Atom PDF