Project

General

Profile

Emulator Issues #12375

Mouse Calibration not centered

Added by Veggieoskibroski about 2 months ago. Updated about 2 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

So, I've installed Dolphin, and I don't have a controller or anything, so I'm trying to use Mouseinput for the cursor on Dolphin

When I try to use Dolphin, in any game, it's always off-center. By a lot

Even after calibrating it. It doesn't work. While my mouse is close to the center of the screen, the emulated position is off the screen to the top-left. I've tried multiple times to calibrate it.
I also tried to use the "Recenter" button, but it does absolutely nothing

image_2021-01-02_183356.png (1.08 KB) image_2021-01-02_183356.png Here's what the calibration shows when my mouse is around the center. While it's at center, the emulated position is off the screen to the top-left Veggieoskibroski, 01/03/2021 12:33 AM
image_2021-01-02_184756.png (18.4 KB) image_2021-01-02_184756.png Pointer input settings Veggieoskibroski, 01/03/2021 12:47 AM
8153
8154

Related issues

Is duplicate of Emulator - Emulator Issues #11873: Attempting to calibrate mouse cursor inputs is confusingAccepted

History

#1 Updated by filoppi about 2 months ago

Show a screenshot with your whole input settings related to that as well.

#2 Updated by Veggieoskibroski about 2 months ago

8154

filoppi wrote:

Show a screenshot with your whole input settings related to that as well.

It is added to this post as a file

#3 Updated by filoppi about 2 months ago

The "Cursor" axes are relative to the game window/widget space when there is one, or to the main dolphin window when there isn't one. So not the screen as you have mentioned.
The "Axis" axes (which are also for the mouse) give the mouse offset from the previous frame, to use that, you need to enable "Relative Input" on the wiimote settings, so it will accumulate the offsets and use that to move the wiimote "cursor".
Guessing you are on Windows anyway?
This is probably just a mistake in setup.

#4 Updated by filoppi about 2 months ago

Yeah, disable "Relative Input" if you are using the "Cursor" axes. Should fix it.

#5 Updated by Billiard26 about 2 months ago

#6 Updated by Billiard26 about 2 months ago

  • Status changed from New to Duplicate

Also available in: Atom PDF