Emulator Issues #12383

SD card isn't accepted by Photo Channel and ACCF

Added by m1dolphinYee 3 months ago. Updated 3 months ago.

% Done:


Operating system:
Issue type:
Relates to usability:
Relates to performance:
Relates to maintainability:
Regression start:
Fixed in:


Game Name?

Animal Crossing: City Folk
Wii Photo Channel

Game ID? (right click the game in the game list, Properties, Info tab)

RUUE01 (0001000052555545) [Animal Crossing: City Folk]

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

b32361fa849d61d07a6507d796b32b17 (Animal Crossing: City Folk)

What's the problem? Describe what went wrong.

After making a custom 2GB sd.raw using the steps at, I tried using it in Animal Crossing: City Folk and the Photo Channel, but they wouldn't accept it, saying that "the device is unrecognized" and "the SD card data is corrupted", respectively.

What steps will reproduce the problem?

  1. I followed the steps in the Virtual SD Card Guide: using hdiutil to make sd.raw.dmg, doing that "mv" thing and making it sd.raw, and checking "Insert SD Card in Dolphin>Config>Wii
  2. I went to Dolphin>Tools>Load Wii System Menu 4.3U
  3. I opened the mentioned games and tried to do things with the SD card. For some reason, pressing the SD card icon on the System Menu didn't bring up any error messages. The entire time, I left the sd.raw file empty.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, version 5.0-13469

Is the issue present in the latest stable version?

No, meaning I don't use the stable version and so I haven't tested it.

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool and anyone who is building Dolphin on their own can use git bisect.)


If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here:

It's not graphical-related, so......

What are your PC specifications? (CPU, GPU, Operating System, more)

I'm using the MacBook Air (M1, 2020) with 8-core GPU, order#

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

I've attached screenshots, as well as a ZIP of the sd.raw file I tried to use. I placed the sd.raw in ~/Library/Application Support/Dolphin/Wii/ as per the instructions from the Virtual SD Card Guide.

Screen Shot 2021-01-12 at 12.06.18 PM.png (3.5 MB) Screen Shot 2021-01-12 at 12.06.18 PM.png This is what happens when I press "Digital Camera/Mobile" in the Photo Channel. m1dolphinYee, 01/12/2021 05:43 PM
Screen Shot 2021-01-12 at 11.56.17 AM.png (2.85 MB) Screen Shot 2021-01-12 at 11.56.17 AM.png This is what happens when I try to save a photo in Animal Crossing: City Folk. m1dolphinYee, 01/12/2021 05:43 PM (1.99 MB) This is a ZIP of the sd.raw file I made and tried to use. m1dolphinYee, 01/12/2021 05:53 PM
Screen Shot 2021-01-24 at 4.56.31 PM.png (2.5 MB) Screen Shot 2021-01-24 at 4.56.31 PM.png The Photo Channel shows this screen, instead of an error. m1dolphinYee, 01/24/2021 10:04 PM


#1 Updated by m1dolphinYee 3 months ago

Another thing I noticed about the Photo Channel was that pressing Wii Message Board also says the SD card is corrupted, with the exact same screen. I'm assuming it saves photos to the SD card.

#2 Updated by jpapetti0713 3 months ago

I was able to reproduce the behavior, as well as solve the issue.
Please try these commands to create a new virtual SD Card:

hdiutil create -megabytes 2048 -fs MS-DOS -layout NONE -o ~/Library/"Application Support"/Dolphin/Wii/sd.raw
mv ~/Library/"Application Support"/Dolphin/Wii/sd.raw.dmg ~/Library/"Application Support"/Dolphin/Wii/sd.raw

It appears that Dolphin on macOS does not like the partition structure of the SD Card.
It has /dev/diskX (of the virtual SD card) as a partition table, and /dev/diskXs1 as the data.
Adding the flag "-layout NONE" disables the partitions, and makes the SD work with Dolphin.

#3 Updated by m1dolphinYee 3 months ago


I used the commands you provided to make another sd.raw, and this one works!

Also available in: Atom PDF