Project

General

Profile

Emulator Issues #12389

Super Swing Golf Season 2 Missing Ground Glitch.

Added by LittleSera about 1 month ago. Updated about 1 month ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Super Swing Golf Season 2

Game ID? (right click the game in the game list, Properties, Info tab)

R2PE9B (0001000052325045)

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

b425efd67c219de134e1c58553f6708f

What's the problem? Describe what went wrong.

The ground texture will always disappear entirely after clearing any missions then starting another.

What steps will reproduce the problem?

Enter Tour Mode and select any mission on the world map.
Play as usual and clear it. (The ground should be there at this point)
Once back to world map, select a new mission (or the same one again).
The ground will be missing entirely. (It has happened every attempts so far)

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-13493

Is the issue present in the latest stable version?

I did not test but the issue has been around for a while, since long before the latest stable version.

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

Screenshots will be provided to compare what it is like before and after the bug happens.

What are your PC specifications? (CPU, GPU, Operating System, more)

CPU: Intel i7 9700k, GPU: GTX 1660Ti, OS: Windows 10.

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

The graphic configs were left on default aside for native x2 resolution. Native resolution was tested and same bug happened. OpenGL, DX12 and Vulkan were also tested.

R2PE9B_2021-01-21_00-09-08.png (913 KB) R2PE9B_2021-01-21_00-09-08.png Before the bug happens I LittleSera, 01/21/2021 05:19 AM
R2PE9B_2021-01-21_00-09-35.png (1.19 MB) R2PE9B_2021-01-21_00-09-35.png Before the bug happens II LittleSera, 01/21/2021 05:20 AM
R2PE9B_2021-01-21_00-18-19.png (829 KB) R2PE9B_2021-01-21_00-18-19.png After the bug happens I LittleSera, 01/21/2021 05:20 AM
R2PE9B_2021-01-21_00-18-38.png (863 KB) R2PE9B_2021-01-21_00-18-38.png After the bug happens II LittleSera, 01/21/2021 05:21 AM
Super Swing Golf S2 Fifo Log I.dff (1.21 MB) Super Swing Golf S2 Fifo Log I.dff Fifo Log before the bug LittleSera, 01/21/2021 05:40 AM
Super Swing Golf S2 Fifo Log II.dff (1.95 MB) Super Swing Golf S2 Fifo Log II.dff Fifo Log after the bug LittleSera, 01/21/2021 05:50 AM
8172
8173
8174
8175

History

#1 Updated by iwubcode about 1 month ago

Thank you for the bug report. Can you provide a fifolog of the issue?

#2 Updated by LittleSera about 1 month ago

My bad... I was not sure what to do with this but I have provided a fifo log for both before the bug and after the bug.

#3 Updated by JMC4789 about 1 month ago

Can you try disabling Store EFB Copies to Texture Only. I seem to remember that doing something.

#4 Updated by LittleSera about 1 month ago

Alright, so I tested the above solution (Disabling 'Store EFB Copies to Texture Only' without changing anything else) during two sessions of 1 to 2 hours each and the glitch never happened. No other problems noticeable aside of missing hole but that does not ruin the actual gameplay. It only disappears visually a little during shot.

Also available in: Atom PDF