Project

General

Profile

Emulator Issues #12396

motion plus controls don't work

Added by Anonymous 3 months ago. Updated 20 days ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Wii Sports Resort RZTE01
[Put Game Name here]
WSP2 US(P) (Disc 0, Revision 1)

Game ID? (right click the game in the game list, Properties, Info tab)

[Put Game ID here]
RZTE01 (00010000525a5445)

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

[Put MD5 Hash here]
4708c98e6b3426ee2744272f2e83736b

What's the problem? Describe what went wrong.

[Description here]
motion plus controls don't work. When I'm trying the motion plus controls using for TASing, it seems like they don't response to the input values of the emulated wii remote. The X,Y and Z wii remote orientation in the TAS input does nothing and it doesn't work when I play Wii Sports Resort Golf. Is there a way to update them to make motion+ TASing possible? So, I can have full control over the wii motion plus controls to make a proper Golf TAS. It's hard or difficult to tell what the directions meant in TAS input but, they don't work

What steps will reproduce the problem?

[Reproduction steps here]
That's difficult to tell. If you trying to using the TAS input for TAS motion controls, they just don't work well. The swing wii remote orientation just don't work

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.
Yes, they have in all development versions of Dolphin have this issue with it
[Version number here]
5.0-13497
Is the issue present in the latest stable version?
Not sure because, I don't use a stable version of Dolphin. Hard or difficult to tell. Yes, I think so, yeah.
[Yes/No and version number here]

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)
Not sure what you mean by the broken version of Dolphin but, I use at the moment (atm) Dolphin version development 5.0-13386
[First broken version number here (if applicable)]
Dolphin 5.0 stable

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer
I have no graphical issues
[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)
I don't know, haven't check this before
[PC specs here]
I don't know

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Hm, I think I'm clear enough about this problem
[Anything else here]


Related issues

Is duplicate of Emulator - Emulator Issues #12443: Feature request: Can we have a TAS input with and for the MotionPlus?New

History

#1 Updated by JosJuice 3 months ago

Is this about TAS Input specifically, or does MotionPlus not work even when using "normal" controls (mapped to a keyboard or gamepad)?

#2 Updated by Anonymous 3 months ago

JosJuice wrote:

Is this about TAS Input specifically, or does MotionPlus not work even when using "normal" controls (mapped to a keyboard or gamepad)?

TAS input is for the emulated wii remote I'm using and with the X,Y and Z input values into it. I've tried both using because, the TAS input window seems like it doesn't support the wii motion plus because, it missing degrees of movement for the MotionPlus controls. I've tried mapping them for the swing controls but, they are so inconsistent to using. So, I'm asking Jos: Is there maybe a way to make motion+ TASing possible? This is not specifically referring to the TAS input, it's for both and both don't work. I can't make a good TAS in Wii Sports Resort

#3 Updated by Anonymous 3 months ago

They both don't work as for the TAS input and mapping them to keyboard controls. They do nothing

#4 Updated by Anonymous 3 months ago

TAS input is for the emulated wii remote I'm using and with the X,Y and Z input values into it. I've tried both using because, the TAS input window seems like it doesn't support the wii motion plus because, it missing degrees of movement for the MotionPlus controls. I've tried mapping them for the swing controls but, they are so inconsistent to using. So, I'm asking Jos: Is there maybe a way to make motion+ TASing possible? This is not specifically referring to the TAS input, it's for both and both don't work. I can't make a good TAS in Wii Sports Resort

#5 Updated by JosJuice 20 days ago

  • Is duplicate of Emulator Issues #12443: Feature request: Can we have a TAS input with and for the MotionPlus? added

#6 Updated by JosJuice 20 days ago

  • Status changed from New to Duplicate

Also available in: Atom PDF