Project

General

Profile

Emulator Issues #12422

Dolphin bar issues

Added by iGom 3 months ago. Updated about 2 months ago.

Status:
Accepted
Priority:
High
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
5.0-13221
Fixed in:

Description

So I just got my Mayflash Dolphinbar (with latest firmware v09 from Apr 1,2017) and it generally connects my Wiimots to the Dolphin with no problem, but the pointer movement is not smooth as you can see in my video (I checked other videos on YouTube and the movement was much smoother) and it seems that after selecting active screen areas, the pointer starts to activate them constantly (I don't know how to exactly explain this behaviour, because English is not my native language, I'm sorry Confused)I checked the range up to 2.5 meters.
These issues only occur with games, not in the Wii System Menu

Checked in the last Dev version 5.0-13671 and the last Beta version 5.0-13603, later found out these issues dont occur on latest stable bulid from 2016
Windows 10 20H2 19042.804

My video: https://youtu.be/LJX6ZhOxrL4

Someone on the Dolphin forum had exactly the same problem as me and using the older version 5.0-11195 fixed the problems for me too. https://forums.dolphin-emu.org/Thread-dolphin-bar-ir-pointer-problem


Related issues

Has duplicate Emulator - Emulator Issues #12465: Wii Mote lag in Super Mario Galaxy 1&2Duplicate

History

#1 Updated by JMC4789 3 months ago

Can you bisect to a more exact build? a 5 year range doesn't really help us much with determining what may have caused the issue. If you cut the range in half and bisect it, it's possible we could find out who change the behavior and how, which will let us assign this to someone.

#2 Updated by iGom 3 months ago

I will try to find with version after 5.0-11195 breaks it for me

#3 Updated by JMC4789 3 months ago

Ah sorry, I missed that. Yeah, that makes the range much smaller. If you can find out what change broke it that'd be great. My DolphinBar no longer has working infrared so I can't verify it.

#4 Updated by iGom 3 months ago

so far I found a bulid that started breaking dolphinbar - https://dolphin-emu.org/download/dev/d31249593421dcdb4f6ef09485ec7e3e96cb4632/

#5 Updated by JMC4789 3 months ago

  • Priority changed from Normal to High
  • Assignee set to Billiard26
  • Status changed from New to Accepted

#6 Updated by JosJuice 3 months ago

  • Regression start set to 5.0-13221
  • Regression changed from No to Yes
  • Milestone set to Current

#7 Updated by iGom 3 months ago

I just found isssues are fixed as long as option Enable Speaker Data is enabled in controller settings after 5.0-13221

#8 Updated by markus40 about 2 months ago

I can confirm enabling Speaker data makes the cursor work smooth again.

Arch Linux, dolphin-emu 5.0.r13772.6c23e163e1-1 package

Also on the newer 1:5.0.r13869.a45a0a2066-1 and dolphin-emu-git 5.0.r13871.gbc4d0b3ef8 packages.
But on those packages Dolphin bar is not working when I run games from the command-line (dolphin-emu -b -e /path/to/iso). Wiimote connects (rumbles and notification at boot) but there goes something wrong when game is loaded with error message "communications with the Wii Remote have been interrupted.".

Strange enough Dolphin Bar and the Wiimote work when I start games from the Dolphin GUI.
Shall I make a ticket for this?

#9 Updated by JosJuice about 1 month ago

#10 Updated by JosJuice about 1 month ago

  • Is duplicate of Emulator Issues #12355: Real Wii Remote / Wiimote - Cursor / Pointer Lagging and Stuttering with Speaker Data Disabled in Mario Galaxy 1 & 2 et al. added

#11 Updated by JosJuice about 1 month ago

  • Is duplicate of deleted (Emulator Issues #12355: Real Wii Remote / Wiimote - Cursor / Pointer Lagging and Stuttering with Speaker Data Disabled in Mario Galaxy 1 & 2 et al.)

Also available in: Atom PDF