Project

General

Profile

Emulator Issues #12426

Transparent box in top left corner of screen (R2VE01)

Added by birdonwheels 5 days ago. Updated 4 days ago.

Status:
Accepted
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
4.0-8010
Fixed in:

Description

Game Name?

Sin and Punishment 2 (Disc 1, Revision 0)

Game ID? (right click the game in the game list, Properties, Info tab)

R2VE01 (0001000052325645)

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

1da681618b9224e5ad04b3dca5b9fb15

What's the problem? Describe what went wrong.

transparent Box with a dark outline appearing in top left corner.

What steps will reproduce the problem?

Starts from when the main menu appears and persists into gameplay.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes 5.0-13690

Is the issue present in the latest stable version?

?

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

5.0-13688

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)
* Operating System: Windows 10 Pro 64-bit (10.0, Build 19042) (19041.vb_release.191206-1406)
* Language: English (Regional Setting: English)
* BIOS:UEFI
* Processor: Intel(R) Core(TM) i5-9600K CPU @ 3.70GHz (6 CPUs), ~3.7GHz
* Ram: 16GB
* Graphics: Nvidia RTX 2080 8GB VRAM

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

I've tried adding EFBToTextureEnable = False to this game's config but it doesn't seem to change anything. (R2VE01.ini)

Dolphin 2021-02-20 14-51-44.png (1.28 MB) Dolphin 2021-02-20 14-51-44.png screenshot of title screen. notice the box in the top left. birdonwheels, 02/20/2021 07:52 PM
Dolphin 2021-02-20 14-55-48.png (1.46 MB) Dolphin 2021-02-20 14-55-48.png screenshot of gameplay. the box is still in the top left. i birdonwheels, 02/20/2021 08:07 PM
R2VE01 titlescreen fifo diff.zip (3.52 MB) R2VE01 titlescreen fifo diff.zip diff file of title screen in a zip archive birdonwheels, 02/20/2021 08:10 PM
R2VE01 gameplay fifo.zip (4.89 MB) R2VE01 gameplay fifo.zip diff file of gameplay in a zip archive birdonwheels, 02/20/2021 08:11 PM
Software.jpg (601 KB) Software.jpg JMC4789, 02/20/2021 09:49 PM
8235
8239
8242

History

#1 Updated by Miksel12 5 days ago

This also happens on 5.0 but seems to be absent on older builds: https://www.youtube.com/watch?v=huI3g69hDO4
Disabling all enhancements doesn't help. Doesn't happen with the software renderer.

#2 Updated by pokechu22 5 days ago

Try adding this to the game INI:

[Video_Hacks]
EFBEmulateFormatChanges = True

#3 Updated by Miksel12 5 days ago

That is the same as disabling Ignore Format changes right? I did disabled that but it still showed the issue.

#4 Updated by JMC4789 5 days ago

I'm testing this an neither works. Appears to be some kind of issue with the EFB Copy area overrunning by a small amount.

#5 Updated by JMC4789 5 days ago

8242

Works in Software Renderer

#7 Updated by JosJuice 4 days ago

  • Regression start set to 4.0-8010
  • Regression changed from No to Yes

#8 Updated by JMC4789 4 days ago

I don't know if this regression is right, there may have been an emulation bug before preventing EFB copies from working correctly. I think it's worth leaving for now until we know for sure htough.

#9 Updated by birdonwheels 4 days ago

pokechu22 wrote:

Try adding this to the game INI:

[Video_Hacks]
EFBEmulateFormatChanges = True

Gave it a try. The box is still the same with it set to true or false.

Also available in: Atom PDF