Project

General

Profile

Emulator Issues #12431

Hotkeys not working in Bluetooth Passthrough mode with keyboard

Added by mrpenguinb about 2 months ago. Updated about 2 months ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Any game, even GC

Game ID? (right click the game in the game list, Properties, Info tab)

Any game, even GC

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

[Put MD5 Hash here]

What's the problem? Describe what went wrong.

When Dolphin is set to connect Wii remotes in Bluetooth Passthrough mode, the Hotkeys bound for the keyboard do not work.

What steps will reproduce the problem?

Switch to Bluetooth Passthrough mode, launch a Wii game and try pressing Esc, Alt + Enter etc. Nothing will happen.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

[Version number here]

Is the issue present in the latest stable version?

No.

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

5.0-13535 is broken. 5.0-13533 is the last working build.

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

I am using an official Wii Bluetooth adapter.

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

[Anything else here]

History

#1 Updated by mrpenguinb about 2 months ago

The issue is still present in the latest development versions/builds.

#2 Updated by JMC4789 about 2 months ago

You said to me earlier that this issue got accidentally resolved somehow?

#3 Updated by mrpenguinb about 2 months ago

JMC4789 wrote:

You said to me earlier that this issue got accidentally resolved somehow?

Yeah. Not sure exactly how, but I think it was related to me adjusting the volume in the Volume Mixer for System Sounds. It is really odd, with everything now working perfectly fine now.

#4 Updated by leoetlino about 2 months ago

  • Status changed from New to Invalid

Marking this as invalid then, as the version numbers don't really make sense (the relevant commits don't touch Bluetooth passthrough at all).

#5 Updated by mrpenguinb about 2 months ago

leoetlino wrote:

Marking this as invalid then, as the version numbers don't really make sense (the relevant commits don't touch Bluetooth passthrough at all).

The issue isn't related to Bluetooth anymore.
The issue occurs after closing a game once or twice, with none of the Hotkeys work anymore until restarting Dolphin.

Also available in: Atom PDF