Project

General

Profile

Emulator Issues #1245

Huge Memleaks in Wii (more noticeable in RE Umbrella Cornicles

Added by darkvalen21 over 11 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1.
2.
3.

What is the expected output? What do you see instead?

What version of the product are you using? On what operating system?

Please provide any additional information below.

History

#1 Updated by darkvalen21 over 11 years ago

Sorry, I clicked on submit without entering any info. If you want to rename go ahead :)
Issue: Huge Memleaks in some Wii Games (more noticeable in RE Umbrella Chronicles)

What steps will reproduce the problem?
1.Open RE Umbrella Chronicles (RE:UC), MK Wii, RE 4 Wii, or Metroid Prime 3 in rev. 3364
2.Start the game and pause (not necessary to see the problem, but it helps)
3.Open Task Manager. In RE:UC you will see memory going up in the range 30MB/s and in
the other games the memory goes up about 3-5 MB/s

What is the expected output? What do you see instead?
The games start fine, but after a short period of time afore mentioned games crash.
Only happens in Wii games in my tests. GC games don´t suffer this problem.

What version of the product are you using? On what operating system?
Happens in all versions AFAIK , tested with 32 and 64 bits, IL and normal builds revs
3364 for MP3 and 3900 and up for the rest of games.

Please provide any additional information below.
The crash time depend of the amount of mem leak. When the memory tops your physical
limit in the system or 2GB if you use 32 bits, dolphin will crash. If you overlay
some statistics in RE:UC, the text. counter goes up even in pause.

#2 Updated by GCNWIIUploader over 11 years ago

are you using an Ati card?

#3 Updated by darkvalen21 over 11 years ago

I have 2 machines, one with a 4890 and other with Nvidia 8800 gtx. Both gave the same
problem in the games mentioned. I know about the leak in ATI cards.

#4 Updated by sskkiipp over 11 years ago

did you try newer revs? r3364 is pretty old :)

#5 Updated by darkvalen21 over 11 years ago

read above, 3364 is only for MP3, the rest of the games had been tested with 3900+ ;)

#6 Updated by Anonymous over 11 years ago

so the leak has always been there?

#7 Updated by darkvalen21 over 11 years ago

Well, not many games of Wii have been working reasonably well till recent revisions,
so I couldn´t test them to see if the leaks had been there always. I will post more
results here from older revisions ASAP

#8 Updated by darkvalen21 over 11 years ago

ok, with 9.3 CORRECT revision, the memleaks are less severe. I´ve been trying
different revision of Open GL drivers with dolphin and 9.7 is the worst by far,
causing the leaks of nearly 50 MB

9.3 - 1-4 MB/s in RE:UC (normal scenario?)
9.4 - 15 MB/s in RE:UC
9.5 - 20 MB/s in RE:UC
9.6 - 35-45 (sometimes 50 MB/s) in RE:UC
9.7 - 40-50 MB/s in RE:UC

if any of you want to test the leak with other games simply copy atio6axx.dll from
any catalyst you want to test into your dolphin folder.

The leak with Nvidia are less severe, but still exists. (3-6 MB/s in RE:UC with 182.50)

#9 Updated by marcus over 11 years ago

  • Status changed from New to Questionable

I can't reproduce this.

Is it still an issue?

#10 Updated by wangdong1982C over 11 years ago

I can replicate the simillar problem with WiiSports, ATI Catalyst 9.7, Win7 x64,
Dolphin 4150, memory leak is about 1-3M/s

#11 Updated by death2droid over 11 years ago

Its a problem with the OpenGL plugin only i think.
Try using the d3d plugin.

#12 Updated by wangdong1982C over 11 years ago

I have a clue, maybe it could help.
JITIL leaks heavily more than non-IL version. eg: In WiiSports, JITIL leaks about 1-
3M/s, but non-IL version only leaks 300K-1M/s. I tested it with Win7 x64 & ATI
Catalyst 9.9 & Dolphin 4357.

#13 Updated by chane2k1 over 11 years ago

i was having this issue with the OpenGL plugin on my ati card too. i have found a fix
update your driver too the catalyst 9.10 beta. the leak is fixed in that version.

#14 Updated by wangdong1982C over 11 years ago

The leak was fixed by Catalyst 9.10, also for my case.

#15 Updated by Anonymous over 11 years ago

  • Status changed from Questionable to Invalid

Also available in: Atom PDF