Project

General

Profile

Emulator Issues #12453

When Dolphin-emu is started from the command-line Dolphin bar and connected wiimote(s) are not working, Running from the Dolphin GUI works

Added by markus40 23 days ago. Updated 13 days ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
5.0-13850
Fixed in:

Description

What's the problem? Describe what went wrong.

Arch Linux with current Dolphin-emu package 5.0.r13869.a45a0a2066-1,
I also compiled dolphin-emu-git 5.0.r13871.gbc4d0b3ef8-1 which has the same problem.

When I run a game with the command-line "dolphin-emu -b -e /path/to/ISO"
- The game boots and Dolphin bar connected Wiimote rumbles, a notification on screen say Wiimote 1 connected.
- The game boots and the Wiimote is not functioning, the screen displays the error: "communications with the Wii Remote have been interrupted.".
- If I disconnect the Wiimote it will not connect again. The above error stays on the screen and I have to quit Dolphin-emu.

When I run the game from the Dolphin-emu GUI the Dolphin bar connected Wiimote works flawlessly.

When I go back to the previous arch package I had installed, dolphin-emu 5.0.r13772.6c23e163e1-1, both the Dolphin-emu command-line and Dolphin-emu GUI work without problem with the Dolphin bar connected Wiimote

I tested the following packages that were installed before, all of them work:
'dolphin-emu-1 5.0.r13184.2952f99f69-2-x86_64.pkg.tar.zst'
'dolphin-emu-1 5.0.r13495.caff472dbf-1-x86_64.pkg.tar.zst'
'dolphin-emu-1 5.0.r13601.9d04fd1ccb-1-x86_64.pkg.tar.zst'
'dolphin-emu-1 5.0.r13772.6c23e163e1-1-x86_64.pkg.tar.zst'

What steps will reproduce the problem?

  • connect Wiimote to Dolphin bar
  • run game with the command-line: ""
  • At boot Wiimote connects like usual (rumbles, notification indicates connection)
  • Normally the "A" button continues from the boot screen, but this is not happening.
  • When booted and error is displayed: "communications with the Wii Remote have been interrupted."
  • Wiimote is not responding.
  • After disconnecting Wiimote, it will not connect again.

  • connect Wiimote to Dolphin bar

  • Start Dolphin-emu with own GUI

  • Wiimote rumbles when GUI shows indicating it has connected

  • Select game from GUI and start it

  • Notification at boot say Wiimote connected.

- Wiimote works through the game without problem

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Tested it with package 5.0.r13869.a45a0a2066 which show the issue.

I compiled dolphin-emu-git 5.0.r13871.gbc4d0b3ef8 and the issue is also present here.

Package 5.0.r13772.6c23e163e1 of dolphin-emu and packages before are working like it should.

Is the issue present in the latest stable version?

No: 5.0-13603

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

As far as I can see: 5.0.r13869

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

Not applicable

What are your PC specifications? (CPU, GPU, Operating System, more)

AMD 2400G, Arch Linux, 16GB

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Not applicable

History

#1 Updated by Ronald.Garretson 22 days ago

I have also encountered this issue. I tested that the wiimote connection issue from command-line (i.e. frontend like Launchbox) is not present on 5.0-13848 but does exist on 5.0-13850 so the bluetooth change on that build likely caused it.

#2 Updated by JosJuice 22 days ago

  • Regression start set to 5.0-13850
  • Regression changed from No to Yes
  • Milestone set to Current

#3 Updated by f.caruso 13 days ago

I have the same problem on Windows version. Reverting to an old version is necessary to work again.

Also available in: Atom PDF