Project

General

Profile

Emulator Issues #12478

[Windows 10] Keyboard sometimes doesn't work as intended

Added by ds22x 6 months ago. Updated 4 months ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:
5.0-14382

Description

For a while now, whenever I use Dolphin on my ASUS Windows 10 laptop, sometimes the emulator sometimes refuses to accept any inputs from the keyboard (DInput/0/Keyboard Mouse) after launching a game, only allowing me to either use system native shortcut keys like ALT+Escape or ALT+F4 (any sort of input from a controller works fine though).
So far I've tried different renderer backends, exclusive and borderless modes, fullscreen or not, render to main window or separate window, toggle "pause on loose focus", toggle between the Ubershader settings, toggle Progressive Scan Mode, and even went as far as setting the compatibility mode to Windows Vista, but nothing.
Also tried to capture a log to see if it would indicate whenever or not the keyboard was properly initializing, but also nothing.
Weird thing is that on the same machine, when running Linux Mint 20.04, the keyboard works just fine (using the latest beta from Flathub).

History

#1 Updated by sepalani 6 months ago

I have the same issue on my MSI Windows 10 laptop (with Dolphin 5.0-13782).

It disappears if I change the controller settings and click on the Refresh button next to "DInput/0/Keyboard Mouse".
It seems to happen only once per boot as I cannot reproduce it after it's disappeared.

I will try to see if I can bisect it.

#2 Updated by filoppi 6 months ago

#3 Updated by filoppi 6 months ago

You can try this build, I recently wrote a workaround for the issue, but I can't test it because the problem doesn't happen on my machine: https://github.com/dolphin-emu/dolphin/pull/9489/

#4 Updated by Miksel12 6 months ago

I have also had this on my laptop but never on my desktop.

#5 Updated by ds22x 6 months ago

filoppi Would you happen to have a pre-compiled build lying around I could test?
Because I've been trying to build one from your source, but I'm unable to compile it with VS2019.

#6 Updated by filoppi 6 months ago

not sure why, it should build, anyway, here it is, it's even got more fixes so it should theoretically also fix sepalani issue where the KeyboardMouse device disappears:
https://file.io/eV6S6k8nqYlw

#7 Updated by ds22x 6 months ago

So far it seems to fix the problem I'm having!
Need to perform more test though, but I have found a bug involving the hotkeys not working when you have "render to main window" enabled, but other than that it's so far so good.

#8 Updated by filoppi 6 months ago

Well that's nice, though it's a workaround, it just avoids recreating the keyboard/mouse device when you change the render window. I couldn't actually fix the problem with DInput. This fix isn't coming soon anyway, I still got polish to make.

#9 Updated by ds22x 6 months ago

At least I have able to confirm it's a real problem and not me loosing my marbles, so I'll look forward to the day your fix gets implemented.

#10 Updated by filoppi 4 months ago

The fix is in

#11 Updated by JosJuice 4 months ago

  • Fixed in set to 5.0-14382
  • Status changed from New to Fixed

Also available in: Atom PDF