Project

General

Profile

Emulator Issues #12490

Trying to connect two Dualshocks via ds4drv, but only one is detected

Added by ee5cd7d5d 26 days ago. Updated 25 days ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Mario Kart Wii

Game ID? (right click the game in the game list, Properties, Info tab)

RMCE01 (00010004524d4345)

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

8a2843aafd5d11f0706c2e6bc3d19410

What's the problem? Describe what went wrong.

I tried connecting two DualsShocks 4 via DSU Client as described here: https://wiki.dolphin-emu.org/index.php?title=DSU_Client but only one is recognized (DSUClient/0/xxx, DSUClient/1/xxx is missing)

What steps will reproduce the problem?

Connect two DS4 via Bluetooth, open configuration, devices.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Version: 5.0-14002

Is the issue present in the latest stable version?

Unknown - Will test

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

Will test

What are your PC specifications? (CPU, GPU, Operating System, more)

               -`                    pedro@arctic 
              .o+`                   ------------ 
             `ooo/                   OS: Arch Linux x86_64 
            `+oooo:                  Host: Skylake Platform 0.1 
           `+oooooo:                 Kernel: 5.11.13-arch1-1 
           -+oooooo+:                Uptime: 2 hours, 11 mins 
         `/:-:++oooo+:               Packages: 1691 (pacman) 
        `/++++/+++++++:              Shell: zsh 5.8 
       `/++++++++++++++:             Resolution: 1920x1080 
      `/+++ooooooooooooo/`           DE: Plasma 5.21.4 
     ./ooosssso++osssssso+`          WM: KWin 
    .oossssso-````/ossssss+`         WM Theme: ChromeOS-dark 
   -osssssso.      :ssssssso.        Theme: ChromeOSDark [Plasma], Breeze [GTK3] 
  :osssssss/        osssso+++.       Icons: Tela-dark [Plasma], Tela-dark [GTK2/3] 
 /ossssssss/        +ssssooo/-       Terminal: yakuake 

/ossssso+/:- -:/+osssso+- CPU: Intel i7-6500U (4) @ 3.100GHz
+sso+:-.-/+oso: GPU: Intel Skylake GT2 [HD Graphics 520]
++:.-/+/ Memory: 2949MiB / 7868MiB
./

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Tested with ds4drv 0.5.1, letest version available here https://github.com/TheDrHax/ds4drv-cemuhook

History

#1 Updated by filoppi 26 days ago

#2 Updated by ee5cd7d5d 26 days ago

filoppi wrote:

Can you try this branch?
https://github.com/dolphin-emu/dolphin/pull/9489/

It does not build on my system:

[ 23%] Building CXX object Source/Core/InputCommon/CMakeFiles/inputcommon.dir/ControllerInterface/Xlib/XInput2.cpp.o
/home/pedro/Projects/temp/dolphin/Source/Core/InputCommon/ControllerInterface/Xlib/XInput2.cpp:378:1: error: expected unqualified-id before ‘{’ token
  378 | {
      | ^
make[2]: *** [Source/Core/InputCommon/CMakeFiles/inputcommon.dir/build.make:538: Source/Core/InputCommon/CMakeFiles/inputcommon.dir/ControllerInterface/Xlib/XInput2.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:1261: Source/Core/InputCommon/CMakeFiles/inputcommon.dir/all] Error 2
make: *** [Makefile:156: all] Error 2

#3 Updated by filoppi 26 days ago

I pushed a fix (sry I'm not on Linux), should build now.

#4 Updated by ee5cd7d5d 26 days ago

filoppi wrote:

I pushed a fix (sry I'm not on Linux), should build now.

Next crash :)

[ 78%] Building CXX object Source/Core/DolphinNoGUI/CMakeFiles/dolphin-nogui.dir/PlatformFBDev.cpp.o
[ 78%] Linking CXX executable ../../../Binaries/dolphin-emu-nogui
/usr/bin/ld: ../InputCommon/CMakeFiles/inputcommon.dir/ControllerInterface/Xlib/XInput2.cpp.o: warning: relocation against `_ZTVN6ciface7XInput213KeyboardMouse4AxisE' in read-only section `.text'
/usr/bin/ld: ../InputCommon/CMakeFiles/inputcommon.dir/ControllerInterface/Xlib/XInput2.cpp.o: in function `ciface::XInput2::KeyboardMouse::Axis::Axis(double, unsigned char)':
XInput2.cpp:(.text+0xe32): undefined reference to `vtable for ciface::XInput2::KeyboardMouse::Axis'
/usr/bin/ld: warning: creating DT_TEXTREL in a PIE
collect2: error: ld returned 1 exit status
make[2]: *** [Source/Core/DolphinNoGUI/CMakeFiles/dolphin-nogui.dir/build.make:220: Binaries/dolphin-emu-nogui] Error 1
make[1]: *** [CMakeFiles/Makefile2:1557: Source/Core/DolphinNoGUI/CMakeFiles/dolphin-nogui.dir/all] Error 2
make: *** [Makefile:156: all] Error 2

#5 Updated by filoppi 26 days ago

Fixed

#6 Updated by ee5cd7d5d 26 days ago

filoppi wrote:

Fixed

Aaaand next :)

[ 90%] Building CXX object Source/Core/DolphinQt/CMakeFiles/dolphin-emu.dir/Config/Mapping/IOWindow.cpp.o
/home/pedro/Projects/temp/dolphin/Source/Core/DolphinQt/Config/Mapping/IOWindow.cpp:24:10: fatal error: QTooltip: No such file or directory
   24 | #include <QTooltip>
      |          ^~~~~~~~~~
compilation terminated.
make[2]: *** [Source/Core/DolphinQt/CMakeFiles/dolphin-emu.dir/build.make:1210: Source/Core/DolphinQt/CMakeFiles/dolphin-emu.dir/Config/Mapping/IOWindow.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:1601: Source/Core/DolphinQt/CMakeFiles/dolphin-emu.dir/all] Error 2
make: *** [Makefile:156: all] Error 2

#7 Updated by filoppi 26 days ago

Fixed. If there are more, come on dolphin dev irc and write me a pm, I'm filoppi there.

#8 Updated by ee5cd7d5d 26 days ago

filoppi wrote:

Fixed. If there are more, come on dolphin dev irc and write me a pm, I'm filoppi there.

It built this time! But the bug persists. Only one device is being detected: DSUClient/0/DS4. Should I just ping you in the IRC?

#9 Updated by filoppi 26 days ago

Honestly my PR isn't specifically meant to address this potential problem, but similar ones, so I had hoped it could fix it.
Have you tried other emulators, or anything take takes more DSU devices and see if both controllers work there?
Because I know for sure that connecting two controllers on Windows with DS4Windows works, so the problem is either in your DSU client, or on the linux version of dolphin, but I highly doubt the platform can make a difference there as the code is exactly the same.

#10 Updated by ee5cd7d5d 26 days ago

filoppi wrote:

Honestly my PR isn't specifically meant to address this potential problem, but similar ones, so I had hoped it could fix it.
Have you tried other emulators, or anything take takes more DSU devices and see if both controllers work there?
Because I know for sure that connecting two controllers on Windows with DS4Windows works, so the problem is either in your DSU client, or on the linux version of dolphin, but I highly doubt the platform can make a difference there as the code is exactly the same.

Alright! No problem, I was planning to open an issue at the ds4drv Github anyways :) thanks for giving it a shot. I will close this if it turns out to be the client

#11 Updated by ee5cd7d5d 26 days ago

ee5cd7d5d wrote:

filoppi wrote:

Honestly my PR isn't specifically meant to address this potential problem, but similar ones, so I had hoped it could fix it.
Have you tried other emulators, or anything take takes more DSU devices and see if both controllers work there?
Because I know for sure that connecting two controllers on Windows with DS4Windows works, so the problem is either in your DSU client, or on the linux version of dolphin, but I highly doubt the platform can make a difference there as the code is exactly the same.

Alright! No problem, I was planning to open an issue at the ds4drv Github anyways :) thanks for giving it a shot. I will close this if it turns out to be the client

Issue for the client opened here: https://github.com/TheDrHax/ds4drv-cemuhook/issues/16

#12 Updated by ee5cd7d5d 25 days ago

The issue is in the DSU Client. Please reject, as I do not have permission :)

#13 Updated by JosJuice 25 days ago

  • Status changed from New to Invalid

Also available in: Atom PDF