Project

General

Profile

Emulator Issues #12491

Wiimote + Dolphinbar not responding in game when launching dolphin from command line

Added by Regent 26 days ago. Updated 23 days ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

All Wii games likely affected but tested games were Mario Galaxy 1 and Metroid Prime 3

Game ID? (right click the game in the game list, Properties, Info tab)

R3ME01, RMGE01

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

da4fc9304933fe9137ecd5e156a1cf07, f99a97f9ae4dccd1db45e9aaab9cebd8

What's the problem? Describe what went wrong.

See https://forums.dolphin-emu.org/Thread-dolphin-bar-doesn-t-work-when-loading-games-from-command-line.

"I'm using a Mayflash dolphin bar in mode 4 with Dolphin 5.0-13963. Dolphin is set to "emulate the Wii's bluetooth adapter" with real Wii remotes selected and "continuous scanning" on. If I load a Wii game from the dolphin GUI, the dolphin bar works great. However if I drag a game to Dolphin, or launch dolphin from Launchbox (which uses the command line of emulator followed by game path), the wii remote is connected, and vibrates when the game launches, but is unresponsive after that."

I have same issue as this user. Wiimote will vibrate when wii game is launched with --exec="game" but then game complains that no wiimote is connected. I am forced to close the emu and launch from the main GUI window.

What steps will reproduce the problem?

Setup latest dolphin to use dolphin bar with real wiimote as outlined above. Wii games should work fine when launched from main GUI window. Then try to launch using command line with --exec="game path" option and wiimote will vibrate on game start but then game cannot detect wiimote for some reason.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Present in 14013

Is the issue present in the latest stable version?

Not tested

What are your PC specifications? (CPU, GPU, Operating System, more)

Win10
Ryzen 1200 2.7Ghz
GeForce 1060 3GB
16GB Micron Rev.E
Dolphinbar + real wiimotes

History

#1 Updated by Regent 23 days ago

Title should be changed to say "... loading games from command line with --exec" or something similar

Also available in: Atom PDF