Project

General

Profile

Emulator Issues #12593

A Boy and His Blob - Game doesn't run at full speed on latest, regression from previous builds

Added by retroNUC 3 months ago. Updated 3 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
Yes
Relates to usability:
No
Relates to performance:
Yes
Easy:
No
Relates to maintainability:
No
Regression start:
5.0-13553
Fixed in:

Description

Game Name?
A Boy and His Blob

Game ID?
SBLE5G

MD5 Hash?
b836e06ab7c01e2b8b61394e34bdb782

What's the problem? Describe what went wrong.
Failing to get 100% speed on the first main level of the game, even with a decent spec PC (Ryzen 5 3600, GTX 3080) and no enhancements enabled. Able to get full speed in smaller levels of the game, but only 67-68 FPS when unlocked. For a basic 2D game, it certainly seems like there's been a regression.

What steps will reproduce the problem?
Play the first minute of the game, entering the forest level.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.
Tested on 5.0.14731 (latest dev) with both Vulkan and DX12 backends.

Is the issue present in the latest stable version?
No - 5.0 (stable) runs at a full 100% speed in both OGL and DX12 backends, boosting to 150fps (250% speed) when uncapped.

If the issue isn't present in the latest stable version, which is the first broken version?
Will try to bisect in further comments

What are your PC specifications? (CPU, GPU, Operating System, more)
* Ryzen 5 3600
* GTX 3080
* Windows 10 21H1

Is there anything else that can help developers narrow down the issue?
Video recording of issue - https://www.youtube.com/watch?v=0jHM_l9zQDE


Related issues

Is duplicate of Emulator - Emulator Issues #12477: Hard stutter in Arc Rise Fantasia, and possibly othersFixed

History

#1 Updated by retroNUC 3 months ago

Bisected down to 5.0-13553 as the broken build.

https://github.com/dolphin-emu/dolphin/pull/9314 - Jit: Fix correctness issue in dcbf/dcbi/dcbst

#2 Updated by retroNUC 3 months ago

And from a quick search of the bug database, appears to be a known issue with this PR that affects other games, so feel free to add to the list:

https://bugs.dolphin-emu.org/issues/12477

#3 Updated by JosJuice 3 months ago

#4 Updated by JosJuice 3 months ago

  • Regression start set to 5.0-13553
  • Relates to performance changed from No to Yes
  • Regression changed from No to Yes
  • Status changed from New to Duplicate

Also available in: Atom PDF