Project

General

Profile

Emulator Issues #12661

Sonic Riders: Zero Gravity - Fourth Player Screen EFB2RAM issue

Added by JMC4789 3 months ago. Updated 16 days ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Sonic Riders: Zero Gravity

Game ID? (right click the game in the game list, Properties, Info tab)

RS9E8P

What's the problem? Describe what went wrong.

The 4th player's screen in normal races flickers between high resolution and low resolution (with EFB2RAM enabled) and between high resolution and black (with EFB2Tex enabled.)

What steps will reproduce the problem?

Start the game
On the main menu, select normal race
With all 4 GameCube controllers configured to the default controls, you can just mash A to get all of them to select a character.
The issue will be apparent in game, especially with EFB2Tex

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-15077

Is the issue present in the latest stable version?

No

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

Last working build is 5.0-5362
First broken build is 5.0-5366 -> https://github.com/dolphin-emu/dolphin/commit/425a8cb378fca29fcdc8ef52673763a5492fa43b

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

EFB Copy issues usually don't record well for fifologs.


Related issues

Is duplicate of Emulator - Emulator Issues #12200: Bottom right screen flickers in 4 player Sonic Riders Zero GravityAccepted

History

#1 Updated by ZephyrSurfer 16 days ago

This has a duplicate. It's accepted and set as current milestone and regression however.

This is the same as #12200

#2 Updated by JosJuice 16 days ago

  • Is duplicate of Emulator Issues #12200: Bottom right screen flickers in 4 player Sonic Riders Zero Gravity added

#3 Updated by JosJuice 16 days ago

  • Status changed from New to Duplicate

Also available in: Atom PDF