Project

General

Profile

Emulator Issues #12662

Official Wii Remotes Not Recognized or Paired on M1 - MacOS 12.0 Monterey

Added by MtkOrange 3 months ago. Updated 19 days ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Although most users have been able to pair Wii Remotes on M1 without issue using MacOS 11.0 Big Sur, this functionality appears to be broken on every MacOS 12.0 Monterey Public Beta. Wii Remotes fail to be paired or recognized by Dolphin, even when using the post-El Capitan pairing guide.

History

#1 Updated by johnboiles about 1 month ago

I can confirm I'm seeing the same thing on a M1 MacBook Air. Worked great on Big Sur. Does not work on Monterey 12.0.1. Nothing seems relevant in the Console.app logs, but I'm not sure what to look for other than 'Dolphin' and 'Bluetooth'. I also went through the pairing guide (https://dolphin-emu.org/docs/guides/wii-remote-plus-rvl-cnt-01-tr-connection-guide/) with no success.

I do Mac development so I could potentially help here, if anyone has any idea where to start looking.

I was really looking forward to cranking the settings like crazy when my 14" M1 Max gets here next week :)

#2 Updated by m1dolphinYee 19 days ago

This issue really needs more attention! I literally just got a Wiimote to use with Dolphin, only for it to not be able to work >:((((

I've never tried to sync a Wiimote before Monterey, so I don't know about macOS rejecting previously-connected Wiimotes. However, while I was trying to pair my Wiimote, I noticed that there's a lot that's different in Monterey's Bluetooth settings that contradicts the pairing guide:
* When you press the Wiimote's sync button inside the battery cover, macOS will automatically pick it up. First it will show the MAC address, then it will show the actual device name after a while.
* When you click "Connect", pairing will not fail. Instead, macOS will try to make you input a 4-digit code that you can't even see. I can't find a way to use some other method, like a regular passcode. I'm guessing this is some stupid security feature they added.
* Guides online will say to input a code like "0000" or "1234". Neither of these codes work, at least not with my Wiimote. Even entering an ASCII string with the backwards MAC address just causes the Bluetooth settings to say "Passkey mismatch".
* Speaking of the MAC address, right-clicking on an item in the Bluetooth list does absolutely nothing. I have to memorize my Wiimote's MAC address now.
* After getting the password error, I did temporarily see an "Options..." button next to the device name in the list. However, clicking on that just asks me to enter the 4-digit code again.

I'm also on macOS Monterey 12.0.1. After many minutes of trying to sync my Wiimote, the settings showed me it's a "Nintendo RVL-CNT-01".

#3 Updated by OatmealDome 19 days ago

I've done some research into this and have gotten nowhere too.

My Wiimote used to work with my Mac on Monterey, until I removed my existing pairing to test pairing from scratch specifically for this issue. (I paired it while I was on Big Sur.)

The guide on the website / wiki appears to be really outdated. The "Passcode Options" button no longer exists since at the very least macOS Sierra.

I wrote a tiny program to try pairing the Wiimote programmatically (https://github.com/OatmealDome/WiimotePair/), and got nowhere with it. The Bluetooth APIs appear to not function correctly (the pairing start callback isn't called for some reason? perhaps I'm doing something wrong) and pairing eventually fails with an IOKit general error, which isn't very helpful.

The last thing that appears in Console.app that appears to be relevant is this message:

peerDidRequestPairing: User has not previously provided a PINCode for device type 26 & the peer ' , Nintendo RVL-CNT-01-TR, disconnected, Unpaired, , devType: 26, PID: 0x0330, VID: 0x057E>' that has no input capability. Displaying pairing options now.

Specs:
MacBook Pro (2019)
macOS Monterey 12.0.1

#4 Updated by m1dolphinYee 19 days ago

It seems like not only are lots of people having issues with Wiimotes on Monterey, but Bluetooth in general. There are tech news reports saying something like "Monterey's Bluetooth core has been reworked, so tons of Bluetooth devices have stopped working".

I wonder if that's what's going on here? In that case, we'd have to wait until the end of the month for Monterey 12.1 to see if it's fixed.

Also available in: Atom PDF