Project

General

Profile

Actions

Emulator Issues #12752

closed

MacOS Universal builds immediately crash on macOS Mojave (10.14.6)

Added by CelestialAmber about 2 years ago. Updated about 2 years ago.

Status:
Fixed
Priority:
High
Assignee:
-
% Done:

0%

Operating system:
OS X
Issue type:
Bug
Milestone:
Current
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

N/A

Game ID? (right click the game in the game list, Properties, Info tab)

N/A

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

N/A

What's the problem? Describe what went wrong.

All MacOS Universal (x86/ARM) Dolphin builds immediately crash on my Mac. Looking at the crash log, the error is "segmentation fault 11". I tried running the last build with an Intel only build option, and it works fine.

What steps will reproduce the problem?

Open the app.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-15586

Is the issue present in the latest stable version?

Yes

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

5.0-15148 (last version to have a Intel only build on the website)

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

N/A

What are your PC specifications? (CPU, GPU, Operating System, more)

CPU: Intel Core i5 1.8 GHz
RAM: 8 GB
GPU: Intel HD Graphics 6000
OS: macOS 10.14.6

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)


Files

Dolphin Crash Log.txt (59.7 KB) Dolphin Crash Log.txt CelestialAmber, 12/05/2021 01:16 AM
Actions #1

Updated by OatmealDome about 2 years ago

5.0-15586 starts up correctly on my Intel Mac, though I'm running Monterey. Unfortunately, I don't have a Mojave machine around to test...

The crash log is... quite odd. Not sure why the Objective-C runtime is failing.

Specs:
MacBook Pro 16" (2019)
macOS Monterey 12.0.1

Actions #2

Updated by CelestialAmber about 2 years ago

I was thinking maybe Mojave has issues with Universal binaries, but I'm not sure about that.

Actions #3

Updated by MayImilae about 2 years ago

  • Status changed from New to Accepted
  • Priority changed from Normal to High
  • Milestone set to Current

Tested on macOS 10.13.3 High Sierra, and reproduced this issue. The latest dev version universal build also does not run on that machine. The last intel build, 5.0-15146, does run on 10.13.

Universal Builds should work no matter how old the macOS version is, I mean, it's been a concept in macOS since the PowerPC days. And the lack of any kind of minimum OS requirements in the announcements seems to indicate that is true. I'm pretty sure our builder is just doing something silly right now.

EDIT: 5.0-14295 Universal also fails. That's the very first universal build. Whoops, I wish I tested this.

Tested on system:
MacBook Pro 13in 2012
Intel Core i5-3210M @ 2.5ghz
Intel HD Graphics 4000
MacOS 10.13.3 High Sierra

Actions #4

Updated by MayImilae about 2 years ago

  • Operating system OS X added
  • Operating system deleted (N/A)
Actions #5

Updated by OatmealDome about 2 years ago

I installed a macOS Mojave 10.14.6 VM and reproduced the crash with builds made by the buildbot. However, builds made locally with Xcode 11.3.1 work perfectly fine. It doesn't appear to be Qt related either, since if I copy and paste the frameworks from my local version into the buildbot version, the crash will occurs. I'm honestly baffled.

Looking at the call stack, it appears that the crash occurs when -[NSApplication init] attempts to call +[NSCursor _makeCursors]. Can't find much information on this function on the Internet.

I tried fiddling with the LC_VERSION_MIN_MACOSX field in the Mach-O executable in case it was some sort of weird macOS compatibility issue, but it didn't help. Extracting the x86_64 slice and running that didn't do anything either, so it probably has nothing to do with the universal binary stuff.

Maybe it's something to do with the installed macOS SDK on the buildbot?

Actions #6

Updated by TellowKrinkle about 2 years ago

Looks like it's SDL, which was built with a minimum macOS version of 11.0

Actions #7

Updated by TellowKrinkle about 2 years ago

Not sure if you are, but you have to be careful around grabbing binaries from Homebrew, as they always build for the latest macOS

And check the linker output for warnings like

ld: warning: dylib (/usr/local/lib/libportaudio.dylib) was built for newer macOS version (12.0) than being linked (10.13)
Actions #8

Updated by CelestialAmber about 2 years ago

@OatmealDome What was the cause?

Actions #9

Updated by OatmealDome about 2 years ago

The SDL on the Dolphin build machine is built with macOS 11.0 and higher compatibility, which causes it to be incompatible with 10.13 and 10.14. See TellowTrinkle's replies above.

Unfortunately, the issue is unable to be fixed at the moment due to an ongoing issue on the build machine.

Actions #10

Updated by MayImilae about 2 years ago

  • Status changed from Accepted to Fixed

All fixed! Latest Dolphin Universal Builds now work on High Sierra. Specifically tested 5.0-15697 on my 2012 MacBook Pro with MacOS 10.13.3 High Sierra.

Thank you Oatmealdome for getting it all sorted! And thank you CelestialAmber for bringing it to our attention.

Actions

Also available in: Atom PDF