Project

General

Profile

Emulator Issues #12781

Pokémon Colosseum: Colosseum Battle does not save properly after connecting to Pokémon Sapphire through integrated GBA emulation link

Added by Hanbei 27 days ago. Updated 27 days ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Pokémon Colosseum

Game ID?

GC6E01

MD5 Hash?

e3f389dc5662b9f941769e370195ec90

What's the problem? Describe what went wrong.

Utilizing the integrated GBA emulator, i attempted to connect to Pokémon Sapphire in order to use my team from that game in Pokémon Colosseum's "Colosseum Battle" mode. The connection goes through, my team is properly imported from the GBA game, and gameplay is playable as usual. However, if i for whatever reason close the emulation and then attempt to use the same team once again, any further attempts to save the game will result in an error message reading "The Memory Card in Slot A is not the same Memory Card used to load the save data. Please insert the original Memory Card in Slot A. Save failed!" until the emulation is reset.
The issue can be circumvented by registering your team every time you open the emulator and plan to play one of the challenges in Colosseum Battle, but this means that it is impossible to suspend a run (most notably, the notoriously long 100-battle challenge), close the emulator, and return later, as re-registering the team will clear your run data.

It is possible that savestates could circumvent this issue, but since Pokémon Colosseum has known issues with savestates breaking gci saves, i haven't tried using them.
I have tested this with Pokémon Sapphire, Leafgreen and Emerald. Both of the latter do not exhibit this issue, and by association i assume so does Firered. I do not know whether this issue happens when connecting to Pokémon Ruby.

What steps will reproduce the problem?

  1. Set port 2 as GBA (Integrated), with a Pokémon Sapphire save file with six Pokémon in the party
  2. Start Pokémon Colosseum, go to Colosseum Battle > Solo Battle > Register Pokémon
  3. When prompted, right click the GBA emulator and reset it.
  4. With the team imported, start any challenge and either clear it or save and quit
  5. Reset the emulation
  6. Enter Colosseum Battle once again and either start or continue a challenge
  7. All further attempts to save until emulation reset should now prompt you with the "The Memory Card in Slot A is not the same Memory Card used to load the save data. Please insert the original Memory Card in Slot A. Save failed!" message.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes. 5.0-15723

Is the issue present in the latest stable version, if not, which is the first broken version?

Did not test 5.0, sorry. It was present in 5.0-15445, for what that's worth.

What are your PC specifications? (CPU, GPU, Operating System, more)

CPU: Intel Core i3-6100 @ 3.70GHz
Video Card: NVIDIA GeForce GTX 750 Ti
OS: Windows 10 (64-bit)
16 GBs of RAM

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Pokemon - Sapphire Version (U) (V1.1)-2.sav (128 KB) Pokemon - Sapphire Version (U) (V1.1)-2.sav Pokémon Sapphire savedata Hanbei, 12/30/2021 03:13 AM
01-GC6E-pokemon_colosseum.gci (384 KB) 01-GC6E-pokemon_colosseum.gci Colosseum gci file Hanbei, 12/30/2021 03:14 AM
Dolphin.ini (4.82 KB) Dolphin.ini Dolphin config Hanbei, 12/30/2021 03:17 AM

History

#1 Updated by Pikachu025 27 days ago

Likely a duplicate of https://forums.dolphin-emu.org/Thread-pokémon-colosseum-mt-battle-save-issue

Can you enable the memory card code patch at Right Click in Game List -> Properties -> Patch tab and see if the issue persists?

#2 Updated by Pikachu025 27 days ago

To clarify: Colosseum's Story Mode checks if the last save file it has read matches the save file it's currently overwriting, and if that's not the case, it will complain; that patch disables that check. I was originally under the impression that this is only relevant if you 'go back in time' by loading a savestate that was made before your latest save operation, but it seems like Colosseum Mode has even more aggressive checks for memory card data...

#3 Updated by Hanbei 27 days ago

That does fix it, thank you!

I tried checking for other people with the same issue but i was clearly not thorough enough. I apologize.

Also available in: Atom PDF