Project

General

Profile

Emulator Issues #13041

macOS Metal/MoltenVK: Ubershaders broken with AMD Polaris graphics

Added by nadiaholmquist 11 days ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Super Mario Galaxy
Most likely affects any game.

Game ID? (right click the game in the game list, Properties, Info tab)

RMGP01 (00010000524d4750)

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

a8c962d1922f7521dc4b07348e4e8a51

What's the problem? Describe what went wrong.

When ubershaders are enabled, the shaders will fail to compile when the game is started. Dolphin displays variations of the following error for each shader:

Failed to compile pipeline for Vertex UberShader for 1 texgens and Pixel UberShader for 1 texgens, per-pixel depth: Compiler encountered an internal error

What steps will reproduce the problem?

  1. Use a macOS machine with AMD Polaris graphics, may aslo affect other AMD generations but I don't have the hardware to test that
  2. In the graphics settings, enable hybrid ubershaders using either the Metal or Vulkan backends.
  3. Launch any game
  4. Dolphin will hang for a while, and eventually start displaying the errors mentioned above

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-17357

Is the issue present in the latest stable version?

N/A

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

Not sure, I think I tried it on this machine when Metal support was a PR and it worked then, but I don't quite remember, and builds from before Metal was merged don't seem to work now either.

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel Core i5-6600K
AMD Radeon RX 480
macOS 13 beta 22A5342f

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Logs don't seem to show anything not displayed in the error message mentioned. If there's any way I can get more information to narrow this down, please let me know.

Also available in: Atom PDF